LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Web Server Not Enabling

This may be off topic, but I start to see a trend here.. I'm short of releasing the next version of my software, previously build on LV8.6, now moved to LV2010.. For the last 2 month I've been deploying beta build using LV2010 and everything was working - the other day, before finalizing the last bits and pieces, I suddenly discovered that my remote webinterface was not working anymore.. I'm using the snapshot mode, and as such the user will just use an ip to look at a frontpanel remotely, no interaction. When moving from LV8.6 RTE to LV2010 RTE this never proved a problem.. As the 2010 SP1 shipped I figure I might as well release the software with as up to date as possible a version of LV. Fail!

After looking back and forth over various options it turns out that the niwebserver.conf file has changed the way it addresses the webserver.. 

I fixed the problem by force removing the old niwebser.conf file when the user is updating the program.. This is not very elegant, but for the level required by this particularly application, this is fine.. Not totally in coherence with the thread topic, but since I never managed to get this information from the NI changelog in the SP1 upgrade, I wonder what else on the webserver platform has changed without informing the community...

 

Have a nice sunday..

 

Jacob

 

 

0 Kudos
Message 31 of 44
(3,383 Views)

Has anyone resolved this issue yet?  I have been struggling with LabView Web Services for a month now and have had no luck.  I have installed 2010, then 2010 SP1, then 2011, nothing works. 

 

Web services are enabled, and I have tried running both 32 bit and 64 bit NI Application Web Servers.  Nothing works.

 

I need to come up with a remote monitoring solution that uses web services soon.

 

NI is now touting LabView Web UI Builder as a new product.  None of this means anything if we can't get NI Web Services to work.

0 Kudos
Message 32 of 44
(3,281 Views)

Hi rwestbrook,


@rwestbrook wrote:

 

Web services are enabled, and I have tried running both 32 bit and 64 bit NI Application Web Servers.  Nothing works.

 


If you go to Start >> Run and enter services.msc, then scroll down to the 'NI Application Web Server' listing, does it show the status as 'Started'? If not, if you try to start the service does it give an error?

 

If the service won't start, restart your computer. After the computer has restarted, immediately go to Control Panel >> Add/Remove Programs. Find the LabVIEW 2011 listing and perform a repair on it. After the repair, restart the computer then check the status of the 'NI Application Web Server' service. What is the status of it now?

0 Kudos
Message 33 of 44
(3,266 Views)

Hello:
I'm working with LabVIEW and AJAX to make a web application where I can see and edit shared variables from LabVIEW. It was working fine until, I think, Windows installed some updating stuff. I've tried to start the NI Application Web Server but it doesn't. I can start the NI Application Web Server 64 bit but when I try to Deploy the Build Specifications I got this error:
Error LabVIEW:  (Hex 0xFFFEFA29) LabVIEW Web Services: Target OS differs from INI file configuration. occurred.
Any help?

Thanks a lot 

0 Kudos
Message 34 of 44
(3,123 Views)

I have done everythibng possible to get the web server running on a new machine (I have it running on another machine but had to start it manually on Win7 Pro 64-bit) ... I have tried starting the service manually but it errors out ... I have repaired LV 2011 SP1 as well as the patch and drivers ... but it won't start automaticallly and errors out when I try it manually

 

The "Configure Web Application Server" is grayed out in the Options -> Web Server in LV

 

This is a new machine running Win 7 Pro 32-bit and LV 2011 SP1

 

I cannot continue using my development machine to host all of the web services ... Any help is appreciated 🙂

0 Kudos
Message 35 of 44
(3,105 Views)

I've had further issues going from 10 to 11 that caused non-web server related issues. I had to wipe my machine and install with a fresh 11 SP1 to get everything working again.

0 Kudos
Message 36 of 44
(3,102 Views)

I never had 2010 installed ... I started with 2011

 

LV doesn't even allow me to start the web server since it is grayed out on the Options -> Web Server page

 

This is a very frustrating product 😞

0 Kudos
Message 37 of 44
(3,100 Views)

RGSchmidt,

 

What are the errors that you see when you try starting the service manually?  

Cole R.
National Instruments
Software Engineer
0 Kudos
Message 38 of 44
(3,075 Views)

I have a similar problem when I try to use the Real-Time execution Trace toolkit. The NI System Web Server service is not running, and when trying to start it returns an 1067 error!

 

I haven't been able to strat the service so far and I am running LV 2012 with new modules and toolkits.

 

Please help!

 

Luka

0 Kudos
Message 39 of 44
(3,013 Views)

Hi Luka,

 

A few things you can check - is your firewall blocking any of the NI services? Another possibility is that your service was somehow corrupted during installation. 

 

What exact version of LabVIEW 2012 do you have installed? Did you install the f2 patch for LabVIEW 2012? 

 

If that is the case, you can try to do a repair install of LabVIEW.

 

Regards

 

 

 

0 Kudos
Message 40 of 44
(3,006 Views)