LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Web Server Not Enabling

Whenever I go to the http://localhost:3580/ website to enable the web server, I login as "admin" and leave the password field blank. I switch the web server from 32-bit to 64-bit and click enable. I leave the port as 8080 click apply. I get a dialog that tells me to restart, and I do. After I restart I try deploying my application which says "Web Services Deployment Failed. You must start the NI Application Web Server before deploying a web service." I log back into http://localhost:3580/ and see that my enabled checkbox no longer says "yes" it is back to "no". 

 

I'm assumign that means my server is not enabled, what can I do?

0 Kudos
Message 1 of 44
(8,662 Views)

More info:

 

I'm just trying to run the simple "weather monitoring" example in the web services examples.

 

Worked in 2009 after I checked "enable web server" in the "web server" option.

 

2010 and 2011b's configuration is a little different because it sends you to http://localhost:3580 to make all your configuration changes. After you enabled the web server (like I said before), reboot, and go back in, the web server is still disabled.

 

I did some searching and made my way to Control Panel->Adiministrative Tools->Services and there just so happens to be a service called "NI Application Web Server". I right clicked and selected "start"

 

I got the following error:


Could not start the NI Application Web Server service on Local Computer.
Error 1075: The dependency service does not exist or has been marked for deletion.

I then selected properties to locate the path of the application and it pointed me to "C:\Program Files\National Instruments\Shared\NI WebServer\ApplicationWebServer.exe"

 

I tried to run and and got the standard windows error/debug window. 

 

I then went back to the services properties and noticed that the path was actually ""C:\Program Files\National Instruments\Shared\NI WebServer\ApplicationWebServer.exe" -user"

 

I went to the command prompt and tried running that and got a window titled "NI Services" that said "Failed to start the service".

 

I did notice that on a computer with only 8.6, there is no service called "NI Application Service" only "NI System Web Server".

 

I'm having this problem on my work PC (XP 32-bit) and my home PC (7 64-bit), two completely different systems. Does having 2011 beta installed break something? I can't imagine that this feature made it all the way through 2010 without working.

 

0 Kudos
Message 2 of 44
(8,627 Views)

I'm having the same problem. The web service was working this morning [edit: on LV 2010], then I installed 2010 SP1. I built and tried to deploy my previously-working web service and got:

 

"Web Services Deployment Failed. You must start the NI Application Web Server before deploying a web service.:

 

Then I go to localhost:3580 and click a check on "enabled" and list port 80. Nothing happens. When I re-open the window it's unchecked. Clearly a bug in SP1, right? The only thing I changed since this morning was installing the DSC module but I suspect that's irrelevent.

Message 3 of 44
(8,596 Views)

I'm going to uninstall all my NI software and try installing just 2010 SP1. I'll report with my findings.

0 Kudos
Message 4 of 44
(8,589 Views)

I would try to install just LV 2010 without SP1 since that configuration for sure works; it was when I installed SP1 that it broke.

 

I hope this gets resolved soon, I don't have room for much more downtime. Good luck!

0 Kudos
Message 5 of 44
(8,585 Views)

In the interest of experimentation, installing LV 2010 without SP1 and validating the web service would be the first step; next installing SP1 and verifying the problem would move this into legitimate bug territory.

0 Kudos
Message 6 of 44
(8,584 Views)

I'll do this.... uninstalling takes forever

0 Kudos
Message 7 of 44
(8,571 Views)

Have you configured the initialization file? My program is called E_Chart and the ini file is E_Chart.ini. It has the following items: Note "[E_Chart]"

[E_Chart]
server.app.propertiesEnabled=True
server.ole.enabled=True
server.tcp.paranoid=True
server.tcp.servic="My Computer/VI Server"
server.vi.callsEnabled=True
server.vi.propertiesEnabled=True
WebServer.DirectoryIndex="index.htm"
WebServer.Enabled=True
WebServer.MimeTypes="htm;text/html;gif;image/gif;jpg;image/jpeg;png;image/png;txt;text/plain;html;text/html;jpeg;image/jpeg;css;text/css;llb;application/x-labview-llb;vi;application/x-labview-vi;doc;application/msword;dot;application/msword;bin;application/octet-stream;exe;application/octet-stream;rtf;application/rtf;pdf;application/pdf;ai;application/postscript;eps;application/postscript;ps;application/postscript;csh;application/x-csh;gtar;application/x-gtar;gz;application/x-gz;sh;application/x-sh;tar;application/x-tar;zip;application/zip;hqx;application/mac-binhex40;ua;audio/basic;wav;audio/wav;tif;image/tiff;tiff;image/tiff;xbm;image/x-xbitmap;rtx;text/richtext;qt;video/quicktime;mov;video/quicktime;avi;video/x-msvideo;movie;video/x-sgi-movie;aif;audio/aif;aifc;audio/aif;aiff;audio/aif;aim;application/x-aim;dif;video/x-dv;div;video/x-dv;js;application/x-javascript;pntg;image/x-macpaint;xlb;application/vnd.ms-excel;xls;application/vnd.ms-excel;ppa;application/vnd.ms-powerpoint;ppt;application/vnd.ms-powerpoint;pps;application/vnd.ms-powerpoint;pot;application/vnd.ms-powerpoint;pwz;application/vnd.ms-powerpoint;mid;audio/mid;midi;audio/mid;enc;video/mpeg;m1v;video/mpeg;mp2;video/mpeg;mpa;video/mpeg;mpe;video/mpeg;mpeg;video/mpeg;mpg;video/mpeg;psd;image/x-photoshop;bmp;image/bmp;pic;image/pic;ra;audio/vnd.rn-realaudio;rf;image/vnd.rf-realflash;rm;application/vnd.rn-realmedia;rp;image/vnd.rn-realpix;ram;audio/x-pn-realaudio;rmm;audio/x-pn-realaudio;rnx;application/vnd.rn-realplayer;rt;text/vnd.rn-realtext;rv;video/vnd.rn-realvideo;smi;application/smil;ssm;application/streamingmedia;sithqx;application/mac-binhex40;sit;application/x-stuffit"
WebServer.RootPath=C:\Program Files\National Instruments\LabVIEW 8.2\www
WebServer.TcpAccess="c+*"
WebServer.ViAccess="+*"
DebugServerEnabled=False
DebugServerWaitOnLaunch=False
DefaultDataFileLocation=E:\Data

Some of the items will be generated on the fly. I think WebServer.Enabled=True is the critical item.

0 Kudos
Message 8 of 44
(8,567 Views)

How do you get to this file? There is a WebService.ini file that gets deployed to the web directory [which I can't see because I can't deploy], but that doesn't seem to be what you're referring to. What you're showing seems to be project-specific but web server configuration in LabVIEW 2010 is global and web-based [through localhost:3850]. However, I imagine that a similar config file has to exist for the web-based config page, if only I can find it...

0 Kudos
Message 9 of 44
(8,563 Views)

I tried installing 2010 (not SP1) and still no luck. I think I'm due for a reformat anyways, maybe I'll give that a go.

 

Edit: This time I get an error when I switch between 32 and 64-bit. I didnt get that before.

 

I still cant start the NI Application Web Service from the Admin Tools -> Services Program

0 Kudos
Message 10 of 44
(8,559 Views)