LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Web Server Not Enabling

Good luck with that...

 

There must be a config file somewhere that gets written during the web-based server configuration. Does anybody know where that is? I've spent a great deal of time looking for it with no luck.

0 Kudos
Message 11 of 44
(2,808 Views)

I tried calling Friday and no one seemed to know the answer to any of that. Apparently someone gets assigned to unsolved forum posts so hopefully our problem isn't falling on deaf ears. It is nice to know that someone else is having the same problem as me, unfortunately. I still need to install 10 on my home PC. Didn't get the install done until late last night and I wasn't going to wait around for LV to install.

0 Kudos
Message 12 of 44
(2,800 Views)

First try building the application. After you build the application, Execute the execution file. It will automatically create the initialization file (same as the name of your application name) in the same directory of your executable or where you told it to place it. Try adding the following line to your initialization file:

WebServer.Enabled=True
.

Rerun the program, This should populate the rest of the ini file.

0 Kudos
Message 13 of 44
(2,791 Views)

The weather monitor project doesn't have an executable that is built, just the web service.

0 Kudos
Message 14 of 44
(2,788 Views)

Then you are going to have to build the file by hand and locate where it is going to read the ini file.

0 Kudos
Message 15 of 44
(2,782 Views)

I just found this ongoing topic:

 

http://forums.ni.com/t5/LabVIEW/Error-while-configuring-Application-Web-Server-in-LabVIEW-2010/td-p/...

 

It's directly relevant, though currently unsolved.

 

 

0 Kudos
Message 16 of 44
(2,762 Views)

It may or may not be relevant, the last post on an unresolve error deals with an application that has an executable.

0 Kudos
Message 17 of 44
(2,755 Views)

Hi everyone,

 

I'm looking into what could be causing this problem with the web server.  What kinds of settings do you have under LabVIEW -> Tools -> Options -> Web Server?

0 Kudos
Message 18 of 44
(2,740 Views)

Heads up, after a reformat and a fresh install of 2010 (not SP1). Weather update works correctly. This did not work under my previous setup. 

 

Here are my settings:

Enable Remote Panel Server: Checked

HTTP Port: 8000

Remote front panels: Checked

Snapshot: Checked

SSL: Unchecked

Use Log File: Checked

C:\Program Files\National Instruments\LabVIEW 2010\resource\webserver\logs\access.log

 

Visible VIs: "*" Checked and Allow access, Use Default Checked

Browser Access List: "*" and Allow viewing and controlling selected

 

Application Web Server: http://localhost:3580/#/WebServerConfigExtension;component/WebServerConfigExtensionPage.dyn.xaml

 

Port: 8080

Enabled: Checked (this would never check before)

64 Bit Selected

 

I will try installing SP1 right now

0 Kudos
Message 19 of 44
(2,736 Views)

Installing SP1 broke it.

 

Worked without SP1, installed it and now it doesn't even let me go to the localhost:3580's web service configuration page.

 

Edit: I had to go into admin tools -> services and manually enable NI Application Web Server... something I couldn't do before I reformatted and now the weather update works. 

0 Kudos
Message 20 of 44
(2,728 Views)