Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Unable to load MIFSystemUtility DLL

To solve this error, you must manually delete the MIFSystemUtility registry key.

  1. Open the Registry Editor. (In Windows 10, type regedit into the search bar and press Enter).
  2. Navigate to the following registry key: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\National Instruments\Common\Installer\MIF\MIFSystemUtility
  3. Right click the key MIFSystemUtility key in the file tree and click Delete.

After deleting the registry key, you should be able to install the software without error.

Message 11 of 18

I did this, and it still doesn't work. Any other suggestion?

0 Kudos
Message 12 of 18

The link is not working... 

0 Kudos
Message 13 of 18

Working, thank you very much

0 Kudos
Message 14 of 18

I dont know if you already found a solution and fixed your problem but I fixed mine when I encountered the same problem by going to the package installer, select the items there, and then click the repair button.

0 Kudos
Message 15 of 18

Deleting the registry key worked for me.

0 Kudos
Message 16 of 18

I have the same problem, but the solution u gave doesn't work for me. Any other ideas? 

'An unknown error occurred.

Additional error information:
Unable to load MIFSystemUtility DLL.'

0 Kudos
Message 17 of 18

Hi All,


Installing NI488.2 online or offline will solve the MIFSystemUtility.dll.



Enjoy programming

0 Kudos
Message 18 of 18