LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Showing results for 
Search instead for 
Did you mean: 


Hi All!

I have the same problem as
Herbert had on this forum.... but there was no reply to his question.... if anybody know the anwser, i will be very gratefull. So here is his message copy/pasted:

I'm trying to debug some NXT examples on LV 8.5 such as the Basic using the debug button in the NXT terminal (as described in the example)

But everytime I try this, I'm getting this error message:
Error 1003 occurred at Invoke Node in>

Possible reason(s):

LabVIEW:  The VI is not executable. Most likely the VI is broken or one of its subVIs cannot be located.  Open the VI in LabVIEW using File>>Open and verify that it is runnable.

Method Name: Run VI

VI Path: C:\Program Files\National Instruments\LabVIEW 8.5\vi.lib\addons\NXTToolkit\gcompiler\Backend.LEGO\

0 Kudos
Message 71 of 139

I had the same problem, so here's what I did:

Download the LabVIEW 8.5 NXT toolkit patch to your computer.  I put it on my desktop.  Browse in the patch to the Labview 8.5 folder.  Keep opening folders after the Labview 8.5 folder until you get to the first one with more than one folder in it.  You'll have to forgive me, I'm at a different computer right now and cannot be more specific.  I think you get down to the "addons" folder.  There will be about three folders in there.  Copy and paste them into your NXTToolkit folder on your harddrive which I think is at: C:\Program Files\National Instruments\LabVIEW 8.5\vi.lib\addons\NXTToolkit.  I think I then had to mass compile the thing again using the instructions found in the Getting Started Document for the Labview 8.5 toolkit.  After that, it worked! 

Good Luck!

0 Kudos
Message 72 of 139
Hi all,

I using labVIEW to control Lego NXT. Previously I was working on a MAC OS 10.4 ppc and all was fine. Now I have a new Intel dual core with MAC OS 10.5. And here is the problem, the fantom.framework does not seem to be compatible with Mac Intel. I tried to run labVIEW with Rosetta but in this case the Bluetooth applications do not work.

I really need to make it work so I'm looking for solutions! Is it possible to get the fantom.framework compiled for Mac Intel?

Thanks for the reaply

0 Kudos
Message 73 of 139
MarcC --

The first release of the Fantom framework was not build for Intel-based Macs.  Version 1.0 (which you apparently have) only supports them through Rosetta; version 1.1 runs natively on "Mactels."  Since you've also moved to Leopard (Mac OS X 10.5), though, you'll need the latest patch for 1.1 to prevent problems downloading firmware.

You can download the new driver from LEGO's website:

Hope that helps!
James Blair
0 Kudos
Message 74 of 139
That's it!

Thanks for help, now it works fine. I downloaded "Mac OS 10.5 (Leopard) Firmware Fix".

Again thanks for answering to this basic question.
0 Kudos
Message 75 of 139
I am running Labview 8.2 with the LEGO mindstorm tool kit. My hardware is a macbook pro with 10.4 Labview is running fine, everything is compiled and running on rosette, but whenever i try to open the nxt terminal, Labview quits. I have reinstalled Labview twice and the NXT tool kit three times, but the same problem occurs. ?
0 Kudos
Message 76 of 139
On 18 januari John Smith suggest to download the LV8.5 NXT toolkit patch, to solve the 1003 invoke node error.
Can anyone tell me where i can find/download this patch?
Thanx for your time, Jos
0 Kudos
Message 77 of 139