LabVIEW Interface for Arduino Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Sensor Support Request

I've tried to create a library for the DHT11 and I'm told that it is similar to the RHT03.  You can try my library and I would appreciate if you did because as of yet I've not get anybody to confirm that it works (because I don't have any of these types of sensors to try).

P.S.  Please post in a archive format that everybody can open (i.e. .zip).

Message 11 of 57
(1,814 Views)

Nathan_B. thanks ...i did tried both your library and the Example you made in the other discussion..they dont work i dont know if u have read the datasheet for this sensor its reccives a 40bit data as(8 byte integral RH%+ 8byte decimal RH% +8 byte integral Temp + 8byte decimal Temp +8 byte check sum) you will fined the rest of the logical operation in the datasheet and to make the sensor work you need to adress thes bytes called (MCU hand shake) before the sensor send any info......so i hope that any one can help me ....thanks in advance For your supports

0 Kudos
Message 12 of 57
(1,814 Views)

I don't deal with the low level communication with the sensor because I use a library that was written by someone else to do that.  My code only creates a LIFA command that executes the command from that pre-written library so, if the library works then my code should work.

If my code doesn't work, try using the same library that I used to create my code to see if that part works.  Since it was not written for the RHT03 I can't guarantee that it works.

0 Kudos
Message 13 of 57
(1,814 Views)

so i dont need to complex the things out i just use the library with the example you made and it should work.... is this library made for labview or you just triger some command that get you the final read..cause i do have another working arduino DHT11 library can i use them ....?

thanks for your time

0 Kudos
Message 14 of 57
(1,814 Views)

If you look in the custom firmware that I have with my library you will see that I include an Arduino native library to do all of the communication (you should see the included file listed near the top somewhere).  You should try that library alone to make sure that your sensor is working with it (without LabVIEW).

0 Kudos
Message 15 of 57
(1,814 Views)

ok i wiil give it a shoot and try it with out labview

0 Kudos
Message 16 of 57
(1,814 Views)

ok Nathan_b i tried your library alone in the arduino but seems like its not working ..if you could use the working library that i attach to you and adjust your Labview VI program so that we are atleast sure about something .....that woukd be very helpful

0 Kudos
Message 17 of 57
(1,814 Views)

If you post an archive file that I can open (.zip) then I will do it.  I appreciate your help.

0 Kudos
Message 18 of 57
(1,814 Views)

am very very sorry Nathan_b i did uploaded the wrong file :S:S:...
here is the working DHT library

0 Kudos
Message 19 of 57
(1,814 Views)

nothing new ???? am so lost

0 Kudos
Message 20 of 57
(1,814 Views)