Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

VISA: Error -1073807252 (Hex 0xBFFF006C)

Solved!
Go to solution

Hi nehap,

 

May I ask what you changed the buffer size to?  How did you implement a delay to the input?  A little more context may help with troubleshooting your issue.

 

You also may want to try making a new forum post and reference this one.  Older posts generally have less visibility, and thus will not get as much attention.  Also this one already has a marked solution.  People may not think to check the page, considering there is a solution.  Additionally, you won't be able to mark a solution of your own once you find the answer.

Trevor H.
Technical Support Engineer
National Instruments
0 Kudos
Message 11 of 14
(2,381 Views)

Hi Trevor,

 

Thanks for the reply. Could u please suggest the forum where I can put up this question?

 

I tried posting it in other groups, but I did not receive any response.

 

About the error part, I found out that when I include too many function blocks in my while loop the loop runs very slow and the complete program runs slower and I get that error. I have attached the picture of my VI. I tried putting a while loop on serial communication part but it doesnt help my program as i need continuos inputs to the PID block.

 

Download All
0 Kudos
Message 12 of 14
(2,373 Views)

So to be clear, you are using a cRIO to communicate read serial data?  Are there other tasks the code should accomplish?  If so, what?

 

Having lots of code inside a while loop will slow the loop down, as the loop will not reset until all code inside it is executed.  We do however have a design pattern called producer/consumer which allows for parallelization of tasks, increasing efficiency.  This may be a useful solution to your problem of continuous input.  There is a white paper describing this design pattern, and how to use it.

Trevor H.
Technical Support Engineer
National Instruments
0 Kudos
Message 13 of 14
(2,338 Views)

Thanks! this seemed to work for me. Just trying to read a simple string from an arduino via a TTL to USB converter.

 

I doubled the default value of the buffer, both devices @ 9600.

 

 

0 Kudos
Message 14 of 14
(1,770 Views)