LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Getting flow sensor frequency using FPGA and using DMA FIFO from target to host. Not getting correct number of samples in output TDMS file and unable to get correct number of pulses from flow sensor.

Hi GerdW,

There are 4 wires coming out of the sensor

brown to ni 9205 positive input

white is input of power supply positive

green to input power supply negative and to ni 9205 negative input.

 

I changed the power supply now to a 12 volt, 350 mA one and I am getting the output on oscilloscope as attached. This looks correct, is it?

 

Download All
0 Kudos
Message 21 of 24
(300 Views)

Hi ash,

 

I changed the power supply now to a 12 volt, 350 mA one and I am getting the output on oscilloscope as attached. This looks correct, is it?

Where did you connect your scope?

When you are in Europe (or any other country with a 50Hz main supply) I would suspect you use a cheap power supply with no filtering. Or does your sensor accidentely output a 100Hz signal?

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 22 of 24
(298 Views)

You were right, I checked the power supply, it outputs a signal with peaks of 100Hz instead of giving a dc voltage..

 

The way I connect the scope is, instead of the inputs going into the ni9205, I put in the same wires to the scope.

0 Kudos
Message 23 of 24
(294 Views)

Hi GerdW... Yesterday I got a new flow sensor which is the same model. I now get proper pulses in the scope ..that means after everything.. the flow meter was defective🤦.. I will make the program now and hope for the best

0 Kudos
Message 24 of 24
(285 Views)