LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Function search lockup

Solved!
Go to solution

The first time in a session when I try to use the Functions search from the block diagram it often (several times a week) locks up. An hour glass appears and I let it sit for 5 minutes but labView is then unresponsive and must be killed. If editing multiple VI's only one shows up in the recovery list. Is this a new feature of the 2009 version or is this an old problem?

 

thanks,

 

jvh 

0 Kudos
Message 1 of 5
(2,683 Views)

Hello jvh,

 

I have not come across any known issues in LabVIEW 2009 such as the one you describe. I would try loading the palettes during launch and then checking if you still observe this behavior. You can choose to load palettes during launch by going to Tools >> Options... in the 'Controls/Functions Palettes'. 

What are the specs of the PC you are using (RAM, hard disk space)? What OS runs on it? If the problem still remains, this information may be useful. 

Please post what you observe. 

Vivek Nath
National Instruments
Applications Engineer
Machine Vision
Message 2 of 5
(2,651 Views)

Good Call

Load palletes during launch.  It will cost you time when booting and (on rare occasions)  I've seen my LabVIEW crash during this step on boot.  (I think some of my companies other apps cause the trouble - cuz I NEVER get this at home)

 

Still- if somethings in the way, and you go "unresponsive" loading a pallate,  Its much less of a headache for it to happen BEFORE you've modified any VIs. Smiley Wink


"Should be" isn't "Is" -Jay
0 Kudos
Message 3 of 5
(2,647 Views)
Solution
Accepted by topic author jvh75021

I have Load Panels at Launch set and haven't had any problems, other than that it causes LabVIEW to launch slowly.

 

This is a very important setting if you want to take full advantage of QuickDrop, because that saves QuickDrop from having to load all the palettes the first time it loads, which kills your productivity. And if you aren't using QuickDrop, you're coding too slowly! 🙂

Jarrod S.
National Instruments
0 Kudos
Message 4 of 5
(2,637 Views)

Intel Duo core T7500

2.2 GHz 

2 GB ram

80GB disk 

0 Kudos
Message 5 of 5
(2,618 Views)