LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

FPGA error -63195

Highlighted

I am working with some customer provided VIs for a PXI-7831R FPGA card. I have successfully compiled all of the target VIs they provided on the FPGA card, and am using the same bit file that my customer has used successfully in this same configuration.

 

The Host VI successfully finds the FPGA card (RIO0::INSTR), but when I try to use the FPGA Read/Write Control Function I recieve the following error:

 

Error -63195 occurred at Read/Write Control in Host_PodCom8.vi->Podcom_GetData_SendCommand.vi->SC7000_Get_ADC_Data.vi

Possible reason(s):

NI-RIO: (Hex 0xFFFF0925) The handle for device communication is invalid or has been closed. Restart the application.

 

Any suggestions whould be appreciated.

0 Kudos
Message 1 of 16
(13,052 Views)
Highlighted
0 Kudos
Message 2 of 16
(13,035 Views)
Highlighted

I hadn't seen that, thanks.

Unfortunately the "Automatically close VISA sessions" options is already deselected. Also, I don't see any errors when I run the target VIs themselves, only when I run host VIs that try to access data from a VI running on the target.

0 Kudos
Message 3 of 16
(13,029 Views)
Highlighted

Please see the following disscussions

 

 

one

 

two

Message 4 of 16
(13,024 Views)
Highlighted

Did you ever find another solution????

 

I have tried both options on this page:  http://digital.ni.com/public.nsf/allkb/CB82AC9CBC6C3F2386257241007A06EF

 

The first was just to uncheck the checkbox for automatically close VISA session (mine was never checked in the first place).

 

The other option was to verify that "cleanupVisa=False" was in the LabVIEW.ini file.  I did this but it did not fix my error...

 

ANY IDEAS?????  Please help.

 

Thanks

0 Kudos
Message 5 of 16
(10,967 Views)
Highlighted

Hello queenlooners,

 

With the the last update on this thread having occurred back in 2009, I doubt any of the original posters are still monitoring it.  Let's see if we can get you up and running though.

 

A workaround I've seen when this error pops up is a reformat/reinstall of the software on the cRIO.  The error itself doesn't always give us a lot to go on (other than some driver is pretty unhappy).  
Have you recently upgraded LabVIEW, LabVIEWRT, LabVIEW FPGA, or any other drivers or toolkits?

Is this error occurring on a program that used to work or is it coming from a new project?

Can you create any other projects with simple FPGA bitfiles and get them to run or does everything you try to run on the RIO throw this error?

 

Tell me more about your application.

 

Best regards,

Matthew H.
Applications Engineer
National Instruments
0 Kudos
Message 6 of 16
(10,943 Views)
Highlighted

Hi,

 

We're encountering this problem (and have tried the VISA related solutions given) with a code that has worked for (years) with Labview 8.6 when we've upgraded to Labview2012. We are storing the reference to the FPGA's in a

shift register as we have several that have the same code running - and as it takes too long to open the reference

each time. We can run the code (at snails pace) by reopening the reference each time we make a call, but when

using the shift register to store the reference to avoid reopening repeatedly the code fails and give the above error. Any idea for a solution ?

 

Thanks,

Niels

 

Message 7 of 16
(10,168 Views)
Highlighted

Hello,

 

I'm also having the same error on a PCI-7831R on LabView 2010 which seems to originate here:

 

VI.png

 

This code is being called  approx. 10 times/s and after a couple of minutes it throws either -63195 (The handle ... has been closed) or -52000 (The specified number of bytes could not be allocated) the latter happening more often:

 

Errors.png

 

 

There are many more locations in the code which do a similar read, but only this particular one throws this error.

 

Automatically Close VISA Sessions is unchecked and cleanupVisa=False is set. Otherwise LabView is running fine, no recent updates or anything. The given code was throwing errors like these right from when it was written as far as I can tell.

 

Regards,

solarsd

0 Kudos
Message 8 of 16
(10,063 Views)
Highlighted

I am Having the Same issues with Error - 63195, Please suggest any Solutions to this...

0 Kudos
Message 9 of 16
(8,885 Views)
Highlighted

Me too with myRIO and LabView 2015. I'm trying to trigger an interrupt from pin A15 and get this message. The example IRQ code works just fine.

0 Kudos
Message 10 of 16
(7,210 Views)