Showing results for 
Search instead for 
Did you mean: 

Button/Boolean mouse hover not working on 64 Bit LabVIEW

Hi community,


under LabVIEW 64 Bit I have found out that occasionally the button mouse hover is not working. What happens is that you don't see the hover, but after a click the button switches to TRUE and on mouse leave the button switches to the hover image and is stuck. Really annoying.

Exiting LabVIEW completely and restarting it, fixes the issue sometimes. I can't reproduce the fix. This bug also applies to 64 Bit built executables.

This does not happen at all under 32 Bit LabVIEW. I tried system booleans as well as custom ones. I am using LabVIEW 2017 SP1 64 Bit.


Did anyone encounter this issue too?


Thanks in advance.

Message 1 of 66

Hi milad_the_great,


Have you tried this in other machines? Does this happen in multiple computers?


Additionally, you mention using LabVIEW 2017 SP1 64-bit. In which Operating System are you using the software and finding problems?


Do you have an example of this behavior? Maybe as a screenshot, or a .ctl we can open in the same environment?


Finally, I would be curious to know if this also happens in the new version (2018), if you've had a chance to try it out (perhaps in a VM to avoid changing your current environment).


All the best,

0 Kudos
Message 2 of 66

@milad_berlin wrote:


under LabVIEW 64 Bit I have found out that occasionally the button mouse hover is not working. What happens is that you don't see the hover, 


It would be interesting to see if the Mouse Enter or Mouse Move events are working, when the Boolean doesn't. Adding Mouse Enter or Mouse Move events might even resolve the problem (or crash even worse)...


Do you use any specific input device? Maybe a touch panel or Wacom pen?

0 Kudos
Message 3 of 66

Hi oscarfonseca,


it happens with the normal system booleans of LabVIEW. I am on a Windows 10 x64 machine. I can reproduce this bug on a Windows 10 x64 laptop that i have here. The reason I didn't attach an example, is because its just a system boolean on the front panel. I try to get LV2018 this week and see if it occurs there as well.



0 Kudos
Message 4 of 66

Does it also happen during editing? E.g. if the VI is not running?

0 Kudos
Message 5 of 66

In LabVIEW there are no hover effects during editing. This only happens during execution of dev system or run-time.

0 Kudos
Message 6 of 66

Hi @milad_berlin,


I'm facing the exact same issue! My Hardware & Software specs are same as yours! Did you find any solutions yet? Otherwise we need to report it!



Message 7 of 66



and I thought that I am the only one with this issue :D. Unfortunately I didn't find any solutions yet. I didn't report it, because I didn't find any posts regarding this issue. Maybe we sould do so now.

0 Kudos
Message 8 of 66

Do you know how to report a bug? I'm new to this!

0 Kudos
Message 9 of 66

Thank you very much for letting us know about this, milad_berlin and Achuthaperumal.


I can help you submitting the bug report for this issue. I'm setting up a computer with Windows 10 64-bit and LabVIEW 2017 64-bit to test the behavior and file a reproducible case with the bug.


I would also like to perform a test with LabVIEW 2018 64-bit to see if the behavior persists in the newest version of the software.


Please let me know if you have any additional information that you consider would be useful to investigate the problem.




Message 10 of 66