LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Showing results for 
Search instead for 
Did you mean: 


This article is intended to indicate the installation and configuration process between LabVIEW and educational robot Lego Mindstorms NXT wirelessly, this will enable LabVIEW developers in having a mobile platform for the development of projects and autonomous robots, we need to install some programs the computer:    



0 Kudos
Message 111 of 139



I have a program for the nxt, which doesn't show any errors in LabView.

When I run it on the computer (target to pc), it works.

When I run it on the nxt (target to nxt), it doesn't work.

It tries to start, but after a second it shows "File error!"


What am I doing wrong?


Thank you for your answers!

0 Kudos
Message 112 of 139

would be good to post your poser program to help you, however sometimes this happens when there is erroro wireless link with the NXT brick, the computer checks and brick are paired 

0 Kudos
Message 113 of 139

to verify the link between LabVIEW and the NXT brick must use the tool options menu Tools / NXT Terminal


nxt tool.jpg

0 Kudos
Message 114 of 139

We use a USB cable to connect the NXT to the computer.
As a result, we can change stuff on the NXT through the Terminal.


When we want to download a program (one example is the attachment) to the NXT, LabView doesn't show any mistakes.

But the NXT always shows "File error!" when we want to start the program.

0 Kudos
Message 115 of 139

Hello, you sigiero watching your structures you verify case, as agreagar a delay for your processor does not saturate, tambein keep in mind that you must identify the NXT brick, some time ago I had a similar problem as it does not put the behalf, I send a small modification, I hope you can help

0 Kudos
Message 116 of 139

Thank you for your answer!

This special initialization block could be the solution.

I will test it soon.


0 Kudos
Message 117 of 139

It doesn't work either.

Has someone another idea?

0 Kudos
Message 118 of 139

Sorry, no solution. But I have the very same problem. After playing around with LV 2013 and the NXT-Toolbox (also downloading all available patches for the SW), I am very disappointed about the quality of the Toolbox. I have quite a few programs which used to run smoothly on LabVIEW 2009 and the former version of the toolbox. Nearly none of the programs ran out of the box with the new version of the SW. Is there some regression testing going on at NI for the toolbox functionality?


All my problems have in common that the program runs without errors when "Computer" is the target.

On the target itself ("NXT target"), lots of strange things happen: Shift-registers with a NXT reference don't seem to work... they were producing compile-time errors, so even no rxe-file was created. I removed all those references, and the program finally did compile,

but now with the already mentionen "File error!" line on the NXT display and no program execution. I tried to strip down the problem, but

did not find a suitable explanation (Filenames too long? Compiler producing to big code? Reentrant VIs beeing the reason?)...


For now I am considering to switch back to LV 2009 or 2010 for my LabVIEW course next summer term. With the current stability

of the NXT toolbox, I think my students will not be able to produce working programs, which are usually larger than the one-liners in the examples directory....


BR, Andreas

0 Kudos
Message 119 of 139

I went to Indoesia to talk to a a guy from NI.

He found out the problem and the solution:


The software didn't work, because we red two LEGO color sensors at once in a while loop.

This bug in the software, led the programcrash on the nxt.

He changed my software and now it works. (It was too complicated to remember)


He told me, that next week (it was on the 16.November.2013) will be a patch/update for this problem.

Maybe it helps you.


Greetings from Germany!

0 Kudos
Message 120 of 139