Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

Debugging on Real Time Target - Deployment Issues

Go to solution

Dear Community,


After wiring code for the RT module of my sbRIO 9651 I do extensive testing to verify the intended functionality. For this I lauch my main VI which then deploys the code to my SoM and I can happily go ahead with my debugging session. 

Sometimes however while in the deployment process I get an error saying:


[VI-name].vi loaded with errors on the target and was closed


When I open the VI there are no errors and the VI should work fine one would think.


My workaround so far was to just open the VI, move the terminals and wires round, re-save the VI  and voilá the deployment works. 


This trick only worked for a while, because the deployment error ca occur arbitrarily on different VI's making debugging quite cumbersome.


I then went ahead and only ran the erroneous VI in RT mode again by moving terminals and structures around to get the VI to run in debug mode but it's very time consuming.


Since 3 People are working on this project and we use git-subversioning I also do not want to "touch" the VIs each time just to get the debug session going without actually changing functionallity.


Has anyone encountered a similar experience or possibly found a magic setting to avoid this time consuming matter?


"Anything can be done if you only think about it hard enough..."
"... truth is a lie in disguise!"
0 Kudos
Message 1 of 5

Is your RT code dynamically loading a bitfile to the FPGA of the sbRIO-9651?  The Ethernet ports of the SOM are routed through the FPGA fabric, so loading a new bit file will temporarily disconnect the Ethernet ports, usually right as a VI begins to run and while the debugger is also trying to connect.  Ideally, you should download your bitfile to the FPGA flash prior to running your RT application and then ensure the Open FPGA VI reference is always pointed at the same bitfile you loaded to flash.  


If this isn't the cause of your issue, then I will suggest we take a closer look at your Ethernet infrastructure and settings e.g. static or dynamic IP addresses, switches/routers, direct connection, etc.



National Instruments

To the pessimist, the glass is half empty; to the optimist, the glass is half full; to the engineer, the glass is twice as big as it needs to be has a 2x safety factor...
0 Kudos
Message 2 of 5
Accepted by SerjsVIEW


if the solutions Spex already presented don't do the trick for you, clearing the compiled object cache might help.

For further information, just take a look at the following link:


Why Are My VIs Being Loaded with Errors When Deployed to My Real-Time Target? - National Instruments





Message 3 of 5

In the Project Explorer, go to Tools > Advanced > Clear Compiled Object Cache... , and when the dialog opens, click the Delete button.


Doing this prior to compiling / building any application has resolved similar issues for me.

0 Kudos
Message 4 of 5

Thanks, that solved my Problem!

"Anything can be done if you only think about it hard enough..."
"... truth is a lie in disguise!"
0 Kudos
Message 5 of 5