Quick Drop Enthusiasts

cancel
Showing results for 
Search instead for 
Did you mean: 

Quick drop cause LabVIEW crash

Solved!
Go to solution

Don't why Quick drop start to cause LabVIEW crash.  All version of LabVIEW crashes.

It's ok to drop a ctrl on the FP, or drop a node on the BD.  But when I use any plugin, even ctrl-R, LabVIEW crash every time.

 

Anyone run into this before?

 

I spent a few hours to run a repair, and it does fix the problem last Friday,  but only to find out the problem comes back today.

 

Windows 10 Pro, LabVIEW 2014-2020

 

George Zou
0 Kudos
Message 1 of 9
(1,431 Views)
Solution
Accepted by topic author zou

Hello George.

Do you have any 3rd party Quick Drop plugins installed?
does the error persist if you remove all 3rd party plugins?

 

BR
Jesper

 

GCentral
CTD + CLD + Pythonista
Message 2 of 9
(1,422 Views)
Solution
Accepted by topic author zou

Have you already removed any custom QD plugin VIs you might have added? Seems like a broken plugin could cause this.

Message 3 of 9
(1,421 Views)

Thanks for quick response.

 

But this can't explain the repair works.

After repair, I haven't add any 3rd party plugin yet.

 

It's painful without QD.  I'm so used to QD, it's hard to avoid it.

 

 

George Zou
0 Kudos
Message 4 of 9
(1,407 Views)

Could you provide the following: 

LabVIEW Version that this occurs in. 

List of quickdrop plugins you have installed?

- Customized plugin short-cuts?

 

Best regards

Jesper

GCentral
CTD + CLD + Pythonista
Message 5 of 9
(1,397 Views)

After the repair, remove your LabVIEW.ini file and your LabVIEW Data folder (make backups of course), and then see if things work. That would be the 100% default, no add-ons install of LabVIEW. 

Message 6 of 9
(1,391 Views)

@Jesper

All versions of LabVIEW installed crashed before repair; now only the one I'm using: 2017.

I have a lot of QD plugins, some I made myself.

 

George Zou
0 Kudos
Message 7 of 9
(1,380 Views)

It looks like the QD triggers the crash, but the root cause maybe something else.

 

I was doing VISA Read/Write to a 3rd party instrument, and getting errors.  After I fixed all the bugs, no more crash.

 

That reminds me that I had similar situation before:

https://forums.ni.com/t5/Quick-Drop-Enthusiasts/Is-it-possible-to-create-a-QD-for-quot-disconnect-fr...

 

Kudos to Jesper, Ian and Darren.  Your response help me eliminate other possible causes.

 

I'll let you know if the problem comes back.

 

George Zou
Message 8 of 9
(1,357 Views)

No.  Still crashing.

 

Removing all 3rd party plugin solve the problem.

Jesper and Ian are right on day one.

 

It's my own plugins broken.  SubVIs have been upgraded to newer version.

I know they are broken for a long time.  Don't know why they cause problem now.

 

George Zou
Message 9 of 9
(1,255 Views)