NI Linux Real-Time Discussions

Showing results for 
Search instead for 
Did you mean: 

Issue in mounting NFS share on compactRio-9068

Go to solution


I am trying to mount a nfs share on compactRio-9068 with "mount -t nfs" command but it fails with message: "Connection refused" . Details about the nfs server are as follows:

Linux host "eeiash" running nfs server is running with 64-bit CentOS Linux (Ip Addr:  nfs exports on this server are:

[root@eeiash]# cat /etc/exports

/tmp localhost(rw,sync),sync,no_root_squash),sync,no_root_squash) *(ro,sync)

I could see that /tmp share is exported from server side

[root@eeiash]# showmount -e

Export list for eeiash:

/tmp                 (everyone)

rpcInfo on server host is as follows. Everything sems okay on server side.

[root@eeiash]# rpcinfo -p

   program vers proto   port

    100000    2   tcp    111  portmapper

    100000    2   udp    111  portmapper

    100024    1   udp    905  status

    100024    1   tcp    908  status

    100011    1   udp   1000  rquotad

    100011    2   udp   1000  rquotad

    100011    1   tcp   1003  rquotad

    100011    2   tcp   1003  rquotad

    100003    2   udp   2049  nfs

    100003    3   udp   2049  nfs

    100021    1   udp  33001  nlockmgr

    100021    3   udp  33001  nlockmgr

    100021    4   udp  33001  nlockmgr

    100003    2   tcp   2049  nfs

    100003    3   tcp   2049  nfs

    100021    1   tcp  44065  nlockmgr

    100021    3   tcp  44065  nlockmgr

    100021    4   tcp  44065  nlockmgr

    100005    1   udp   1015  mountd

    100005    1   tcp   1018  mountd

    100005    2   udp   1015  mountd

    100005    2   tcp   1018  mountd

    100005    3   udp   1015  mountd

    100005    3   tcp   1018  mountd

When tried to mount /tmp share on compactRio-9068 (Ip Addr:

admin@compactRio-9068:# mount -t nfs /mnt/iasHome

mount: mounting on /mnt/iasHome failed: Connection refused

I also tried "-v" option with mount command but seems like busybox "mount" on compactRio does not recongnize "-v" option does not provide any details information about failure.

Later, I checked /var/log/messages on server side (on eeiash)

Jul  2 15:31:12 nas mountd[22463]: authenticated mount request from for /tmp (/tmp)It appears

It appears that server has authinticated the request from compactRio client but somehow compactRio fails to establish connection with nfs share and display the error message. I also tried to mount this share on another linux based host which worked fine. Not sure if compactRio needs any additional settings/packages.

Has somebody come across similar issue in past? How do I debug it?




0 Kudos
Message 1 of 14


What login are you logged in as?  Are you trying to do this from an SSH prompt, or via the System  Can you supply the exact command you are using?



0 Kudos
Message 2 of 14

WillsG, welcome!

Can you check to see if there are some NFS utilities that are available that are not currently installed on the target through opkg? Uncomment the feed addresses in /etc/opkg/angstrom-*-feed.conf files (and change the URL to point away from as that mirror went down, point it to just Sorry if it's not exact, working from memory here), then run the following

opkg update

opkg list | grep -i nfs

0 Kudos
Message 3 of 14

Hi TD,

I am logged in to compactRio as admin (root user with uid=0). I am performing this mount operation from ssh prompt. Here is a list of commands I used:

1. ssh to compactRio ( as admin  from other linux host

2. Commands used on ssh shell of compactRio:

     # cd /mnt

     # mkdir iasHome

     # mount -t nfs  /mnt/iasHome

(this commands shows error message: mount: mounting on /mnt/iasHome failed: Connection refused)

Hi BradM,

I will check about the nfs packages and update on this thread soon.



0 Kudos
Message 4 of 14

Hi BradM,

I did update the list of packages from opkg repo feed (src/gz angstrom-base

With "# opkg list | grep -i nfs", I don't see any nfs utilities on updated list. I also tried "opkg list-installed | grep -i nfs" but it returned blank as well.


0 Kudos
Message 5 of 14


Thanks, figured there may be some tools that are needed but not installed (as is the case with CIFS/SAMBA). You may want to try installing util-linux-mount to see if the more-fully-featured version of mount works for you. Another thing to check would be to install a tool like tcpdump (on either the 9068 or the server) or wireshark (on the server) to compare and contrast the two mountings: the working mount from another linux machine and the not-so-work-y mount from the 9068.

0 Kudos
Message 6 of 14
Accepted by topic author WillsG


I did install available "util-linux-ng-mount" but did not help. I had to upgrade "libc6" to get rid of "unsatisfied dependency" for this package. Late, I removed "util-linux-ng-mount" which reverted "mount" link back to busybox.

Do you think there will be some issue for compactRio normal operation due upgraded libc6? Is there a way to downgrade it to previous version ?

Later, I came across following links to get the fix:

Following mount command worked fine and I was able to get the nfs share mounted on compactRio:

# mount -o port=2049,nolock,proto=tcp  -t nfs /mnt/iasHome

Thank you or all help.

0 Kudos
Message 7 of 14

If you test and find no issues, it is reasonably likely that there will be no issues keeping the updated libc6 on the target. Note however that this library did not get nearly the same level of testing on the 9068 as the older 2.11 libc6 did, so it is advisable that you format and reinstall if it is not too inconvenient to do so.

0 Kudos
Message 8 of 14

After getting nfs share mounted through manual shell command, I am trying to mount this nfs share during boot-up time. In order to make that happen, I added following line at the end of the file: "/etc/fstab"  /mnt/iasHome  nfs  port=2049,nolock,proto=tcp  0 0

I verified the accuracy of line by issuing a mount command : "mount /mnt/iasHome"  which worked fine.

However, this mount operation does not work during system start-up. One logical explaination could be that network is not up by the time system tries to mount this share. Is there a way to fix this?

0 Kudos
Message 9 of 14

In the options, you need something to tell the system that it should automatically mount the network share.

X.X.X.X:/tmp /mnt/iasHome nfs auto,port=2049,nolock,proto=tcp 0 0

The other entries in the file are either manually mounted by startup scripts or are already mounted by being the rootfs (as configured) of the system.

0 Kudos
Message 10 of 14