Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Windows hangs at startup when DAQmx is connected via USB

Windows is hanging (no control at all, not even ctrl-alt-del) just after user login when DAQmx's are connected.  We have 3 of them and the system will hang with any one of them connected.


We have completely re-installed the system starting with a fresh install of Windows.  Once everything was installed we plugged in the DAQ's for the first time and they registered fine and everything worked properly.   We restarted the system a couple times and everything still worked.  However, after a power cycle (computer cold start) the system hangs as described at startup consistently.


.. further to the above, if the DAQs are not connected at startup the system will operate fine but will freeze completely as soon as a DAQ is connected.


0 Kudos
Message 1 of 4

Hi Lorne,


It would be helpful to have more information here, what DAQmx devices are you connected?  It sounded like they are USB from what you described but I want to make sure.  Also, is this a laptop or desktop system?  I'm wondering if this might be an issue with the USB controller itself.  Finally, if you can provide the Windows version, as well as the DAQmx driver version, I'd like to check and see if anything looks suspect there.

0 Kudos
Message 2 of 4

Hi Matt...

We have USB-6366-OEM DAQ's.

We discovered that the jumper for the clock battery on the motherboard was not connecting so the system date was getting set to ~2007 at boot time.  This seems to confuse the DAQmx driver, causing a complete system hang.  With the jumper in place (and thus a valid date in the RTC) we have not had any more hang-ups.


Message 3 of 4



Good find!  The DAQmx driver does use the Windows system time to pull a starting timestamp for logging acquisitions, so it's entirely possible that was the case.  This will be helpful for future reference; thanks for lettings us know, and glad you got this worked out!

0 Kudos
Message 4 of 4