Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

NI cDAQ-9174 Not recognized

Solved!
Go to solution

Hello, I'm not sure if this is the right board, but here goes.

 

I have a USB NI cDAQ-9174 that I am trying to use with LabVIEW 2009 and DAQmx 9.1. After I had installed LabVIEW 2009, I thought that it had DAQmx and the device drivers installed with it, so I plugged in the cDAQ. I then realized my error, and installed DAQmx from the disk that came with the cDAQ.

 

Unfourtunatly, the device is not recognized by SignalExpress or MAX. It shows up in Windows device manager as "cDaq-9174" under the heading "National Instruments Device", but NI Device Monitor never detected the device.

 

I uninstalled DAQmx then plugged in the cDAQ to no avail, then uninstalled the driver from the device manager and unistalled DAQmx again and plugged in the cDAQ, same deal. I am now uninstalling all National Instruments software in an attempt to fix this, if it doesn't work I really don't have any clue what to do.

 

If anyone could help out, that would be great. I am working on a HP desktop.

0 Kudos
Message 1 of 27
(13,356 Views)

Just a follow up, un-installing all National Instruments software did not fix the issue. Plugging in the cDAQ after installing a fresh copy of LabVIEW 2009 and DAQmx 9.1 did not bring up the "Install New Hardware" dialog. I have no idea what to do, does anyone know how to get Windows to install it correctly?

0 Kudos
Message 2 of 27
(13,350 Views)
Do you have the options of trying the chassis on a different computer?  Also, which model of HP PC are you using?
Seth B.
Principal Test Engineer | National Instruments
Certified LabVIEW Architect
Certified TestStand Architect
0 Kudos
Message 3 of 27
(13,344 Views)

Seth,

 

I was able to load just DAQmx on a different computer. The device was recognized immediately and worked. I'm not sure how to fix the issue on the machine I'm trying to use it on, so I am going to reinstall Windows (it was just set up, so it's no big deal). This time I will make sure to install DAQmx from the disc before trying to plug it in. If my troubles still persist, then I'll know if it is something with the PC hardware.

 

Thank you,

Luke

0 Kudos
Message 4 of 27
(13,327 Views)

I am also having a similar issue with a cDaq-9174 and Daqmx 9.1

 

I have tried repairing all of the NI Daqmx 9.1 installation components but MAX still does not recognize the device.  It may not be specifiecally related to the cDaq since MAX also will nto recognize my USB-6008 either.

 

All wokred fine last with NiDaqmx 9.0.2

 

Dan

 

For NI AEs:

William Schoettler is working on this SR:7282402

0 Kudos
Message 5 of 27
(13,326 Views)
Solution
Accepted by topic author lukepike

Luke,

 

 

If you get this message in time, hold off on the Windows reinstall, there is one other step I'd like you to try if possible.  Follow the steps in this KB (completely deleting the Data folder in step 7): What is the Process For Removing MAX Database Corruption? 

 

Hopefully, this will be a less painful way of addressing the issue.

Seth B.
Principal Test Engineer | National Instruments
Certified LabVIEW Architect
Certified TestStand Architect
Message 6 of 27
(13,320 Views)

Luke,

 

Another thing to consider is that you may have a bad entry in the Windows Registry that is not being cleared when LV is uninstalled.  This entry was probably created when you connected the cDAQ without the proper NI drivers being installed.  I have in the past as a last resort hand edited the registry to remove stuff like this.

 

Entry should appear under HKEY_LOCAL_MACHINE>SYSTEM>ControlSetxx>Enum>USB

 

P.S.  Thanks again for the robot demo the other night.

Message Edited by Wayne.C on 04-09-2010 08:48 AM
0 Kudos
Message 7 of 27
(13,305 Views)

Seth,

 

Thank you for your help. We did not end up reinstalling Windows, so I tried what you suggested. Following those steps and deleting the Data folder fixed the issue.

0 Kudos
Message 8 of 27
(13,258 Views)

I am having a similar problem and deleting the data folder did not fix the issue.

 

Vista 32 bit

Labview 2009

NI-DAQmx 9.1

 

 I have a cDAQ-9174 with 4 modules (NI9263,NI9401,NI9213,NI9201). I double checked the hardware with a different computer running XP/Labview 2009/NI-DAQmx 9.1 and it worked as it should.

 

On the Vista machine the cDAQ-9174 appears in windows device manager but fails to be recognized by MAX. I have uninstalled and reinstalled all the national instruments software with no change. I have deleted the data folder as suggested with no change. I am unwilling to reinstall windows to make this work (I haven't had to reinstall windows in years - I hope we're not back to that...)

 

Any suggestions?

0 Kudos
Message 9 of 27
(13,126 Views)

Hello kmeloy,

 

First, I apologize for the inconvenience of this issue, I know it must be frustrating.  Hopefully we can resolve this without having to resort to extreme measures.  Could you post screenshots of what the devices show up as in Windows Device Manager and the Hardware IDs for the chassis and a module?  To find the hardware IDs, right click on the device and select properties, then go to the Details tab and select Hardware ID.

 

It will look something like this:

9174 Properties.png 9401 Properties.png

 

Regards,

Seth B.
Principal Test Engineer | National Instruments
Certified LabVIEW Architect
Certified TestStand Architect
0 Kudos
Message 10 of 27
(13,105 Views)