Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQmx Compatibility with NI max

Solved!
Go to solution

Hello,

I am trying to read signal from NI9202 DAQ but when I create the task I get an error which I have attached below.

LabVIEW version:17.0.01

NI Max:17.5

DAQmx: 17.6

 

The DAQmx drivers installed at the start were 17.5 but then I figured out that in order to run NI9202 I need to upgrade the driver to 17.6. When I had 17.5 driver I got an error saying 'Unsupported Hardware'. But when I installed the 17.6 driver I was able to see the NI9202 DAQ name.

 

One solution I tried was to remove the DAQmx driver and install it again, after installation gave out the same error.

 

Second solution I attempted was to uninstall and reinstall everything including all packages still gives out the same error.

 

I need help.

 

Thank you.

0 Kudos
Message 1 of 5
(189 Views)
Solution
Accepted by topic author Mak_2496

First thing I would do is reboot the computer.  If it is still broken, I would update DAQmx to 20.7 (the last version to support LabVIEW 2017 per NI-DAQmx and LabVIEW Compatibility).


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 2 of 5
(159 Views)

Which cDAQ chassis are you using?

0 Kudos
Message 3 of 5
(154 Views)

Thanks, Installing the latest version of DAQmx compatible with the LabVIEW version helped. I was trying the older versions and that's why I was having the issue. 

0 Kudos
Message 4 of 5
(133 Views)

NI cDAQ -9174

0 Kudos
Message 5 of 5
(131 Views)