Lookout

cancel
Showing results for 
Search instead for 
Did you mean: 

Hypertrends and VPN connections

I'm not sure whether I've got a network problem or a Lookout problem in getting a client/server process to function over a VPN.
 
Basically, I've tested a simple Lookout process that logs the value of a pot to Citadel. (ie \\Look1\process1\pot1.LoggedValue)
The process1 displays the value as a digital value and uses a hypertrend to display the historical values. Works fine.
 
Another machine Look2 is on the network (same subnet) and runs a client process. This process also displays \\Look1\process1\pot1.LoggedValue as a digital value and within a hypertrend correctly.
 
A third machine Look3 connects to the above network with a VPN connection through the internet. I cannot see the other computer names (ie Look1 and Look2). I think this is because they are not on the same subnet. But a client process running on Look3 will display the digital value correctly if the IP address is used. ( \\192.168.0.3\process1\pot1.LoggedValue)
 
However, when \\192.168.0.3\process1\pot1.LoggedValue is used in a hypertrend only null values are shown.
 
I've used lookout versions 4.51 and 5.0 with the same result. Any insight would be greatly appreciated.
 
Thank you,
 
Bob Lockert
0 Kudos
Message 1 of 8
(3,910 Views)

Hi Bob,

It sounds like there may be some issue with the Firewall or the Logos Protocol being blocked.  Check out the following links to see if these might help.

Setup Guidelines For The Logos Protocol Across Firewalls
http://digital.ni.com/public.nsf/websearch/F0DE7A1A88D92D6D86256D710049FB40?OpenDocument

Using Lookout, LabVIEW DSC Module, and Network-Published Shared Variables with Firewalls
http://digital.ni.com/public.nsf/websearch/8AE45BBFA1D7025E862570F200642FD8?OpenDocument

Networking Lookout or the LabVIEW DSC Module Across Firewalls
http://zone.ni.com/devzone/conceptd.nsf/webmain/7D0E7F20B1A7C8E486256A39005747F2?opendocument

Hope this helps,

Best Regards,

Steven B.

0 Kudos
Message 2 of 8
(3,889 Views)

Steven,

 

Thanks for the info. The links helped me somewhat understand the Logos part of the Client/Server communications.

All systems are W200o. The Logos ver. on the Server is 4.5.1 and on the Clients it is 4.3 and 4.4 (2 systems)

I don't believe its a firewall problem. I can set it to 'Pass All' with no improvement. I can log all firewall activity and no IP or Port blocking is shown.

The VPN is intended to provide a tunnel through the firewall using encryption/decryption algorithms rather than IP/Port # blocking.

Furthermore, the Client sees the Server process and all the objects within the process. (Through the VPN) However, it does not see data from the database even for the same object names.

I'm currently tryng MAX to view databases. I can see all local databases (ie same subnet) but cannot see remote ones.

???

Bob

 

0 Kudos
Message 3 of 8
(3,842 Views)
Bob,
 
What version of Lookout are you currently using?  Since the Client sees the Server process and all the objects within the process it sounds like it may be an issue with Logos publishing the data from the database.  If possible you might try and upgrade the version of Logos on your client Machines. 
 
Steven
0 Kudos
Message 4 of 8
(3,827 Views)

Well the problem had nothing to do with the VPN or firewalls. It was simply a network issue.

Adding lines such as '192.168.0.3   Look2' to the 'hosts' file solved all the issues. This allowed 'ping look2' to work correctly across the VPN.

Within the hypertrends the IP address was replaced by the computername and all worked OK.

File in question for W2000 is at C:\windows\system32\drivers\etc\hosts

Regards,

 

Bob

 

 

0 Kudos
Message 5 of 8
(3,669 Views)
If you upgrade to Lookout 6, it will break again! Smiley Mad
0 Kudos
Message 6 of 8
(3,293 Views)

??? break again???

How so? I didn't think my problem had anything to do with Lookout or Citadel. My Client machine simply could not resolve the Servers ComputerName with its IP address. IP addresses worked OK for Lookout client to server requests for current pot values etc.

However a hypertrend requests data from Citadel. And the trace names within Citadel include the ComputerName NOT the IP address. So unless the Client knows and uses the correct ComputerName, Citadel won't have it.

Regards,

Bob

 

0 Kudos
Message 7 of 8
(3,283 Views)
Hi Bob,
 
 
It turns out that Hypertrends in Lookout 6 will only display on clients within the server machines local subnet!  When 6.0 first released, hypertrends would not display if linked with an IP address, regardless of whether or not the client was on the same subnet.
 
Near the end of the thread, someone from NI implies that both issues were addressed with fixes, but this is NOT the case from my recent tests.  They did fix the IP resolution problem on local subnet hypertrend client displays but you still cannot get hypertrends to display from an internet client!!!
 
It will be interesting to see how NI responds to my flurry of inquiry on the TRUE status of this issue/fix yesterday.
 
Of course if ANYONE on these forums can say they got it working (work-around or otherwise), I'd love to hear it and how they did it.
 
Cheers,

Ed
0 Kudos
Message 8 of 8
(3,271 Views)