LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

reset hub

Hi all,

 

I'm using an ethernet hub to network 2 homemade electronic boards and collect data from them using labview. The boards use udp for communication.

 

The problem is that each time that I collect data I have to either wait a couple of minutes or unplug the power of the hub in order to collect data again, otherwise it wont work.

 

any idea how to fix it?

 

thanks

sbz

0 Kudos
Message 1 of 16
(2,877 Views)

Hi sbz,

 

Could give us some more info including the you have tken to troubleshot? Do you have firewall software installed?

Joe Daily
National Instruments
Applications Engineer

may the G be with you ....
0 Kudos
Message 2 of 16
(2,848 Views)

I'm just trying to figure out how this is a LabVIEW question. This sounds like a hardware problem with the hub. Actually, why would you be using a hub? Hubs are pretty rare these days, as they've been supplanted by switches.

0 Kudos
Message 3 of 16
(2,837 Views)

there is no  firewall software installed. and also it is a switch not a hub, sorry.

thx guys

0 Kudos
Message 4 of 16
(2,822 Views)

reason that i think its a labview problem is that its possible that the udp close does not close the port when it's networked with 2 instruments. (i have to use udp).

0 Kudos
Message 5 of 16
(2,806 Views)

 


@sbz wrote:

reason that i think its a labview problem is that its possible that the udp close does not close the port when it's networked with 2 instruments. (i have to use udp).


 

Show us some code!

 

Are you always using the same port numbers?

How ofter do you close and re-open the ports?

Are both sides LabVIEW based?

0 Kudos
Message 6 of 16
(2,795 Views)

yes, im using the same port and close it after each measurement. also both sides is labview based. thx

0 Kudos
Message 7 of 16
(2,782 Views)

Why don't you keep the port open for the duration of the run?

0 Kudos
Message 8 of 16
(2,778 Views)

labview gives an error that the port is busy.

0 Kudos
Message 9 of 16
(2,765 Views)

Gives the error when? Please post your code, as your statements are a little too brief to really convey what you're doing.

0 Kudos
Message 10 of 16
(2,759 Views)