LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

odd Modbus error

I'm using LV 2015, 32bit on two W7 laptops, and a cRIO 9036 chassis. I have the same program, configured differently, on all three targets. One laptop has been talking Modbus TCP to an industrial PLC-type controller for years, using a module I wrote specifically for that PLC instance. I recently put that module down on the cRIO. It now talks Modbus TCP to the same PLC at the same time, no problem, no errors.

Then I tried to put that same module on the 3rd target, the second W7 laptop. It returns data, which appears to be correct. But every read of a Modbus channel also returns this error:

 

Error 1 occurred at :  Modbus 7.vi in MICAS Acquisition.vi  Possible reasons:  LabVIEW:  An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @.:  SubVI in SubVIs.lvlib:TCP Master.lvclass:Protocol Write.vi:6190001->SubVIs.lvlib:IP Data Unit.lvclass:Write ADU Packet.vi:1820001->Modbus Master.lvclass:Read Input Registers.vi:5450001->Modbus 7.vi->MICAS Acquisition.vi

 

The firewall on the 3rd platform (2nd laptop) is turned off. All three platforms are plugged into the same Ethernet switch.

 

Any ideas what Error 1 means in this case? I did think that maybe three connections was "marginal" for the controller, so I did try stopping the first laptop and the cRIO and running JUST the 2nd laptop, but it still gets an error!

 

Thanks,

       DaveT

-------------------------------------------------------------
David Thomson Original Code Consulting
www.originalcode.com
National Instruments Alliance Program Member
Certified LabVIEW Architect
Certified Embedded Systems Developer
-------------------------------------------------------------
There are 10 kinds of people: those who understand binary, and those who don't.
0 Kudos
Message 1 of 2
(1,870 Views)

Hey,

 

I found a few different instances where that error comes up. They are slightly different scenarios, but the error seems to be the same. 

 

LabVIEW Error 1 or 6: Input Parameter is Invalid: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P6rgSAC

 

Error 1 Occurred at Open VI Reference:https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019KbxSAE

 

https://forums.ni.com/t5/LabVIEW/build-error-an-input-parameter-is-invalid/td-p/872692

 

 

Let me know if this helps or you have tried these steps already!

 

Thanks,

 

-Brian J. 

0 Kudos
Message 2 of 2
(1,825 Views)