Showing results for 
Search instead for 
Did you mean: 

build error: an input parameter is invalid

I am looking for help with a build error. I am getting the following error message when I try to build a project in 8.5.1:


Error 1 occurred at Open VI Reference in>>>>>>>

Possible reason(s):

LabVIEW:  An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @.
NI-488:  Command requires GPIB Controller to be Controller-In-Charge.

VI Path:

Tom Rhoads
Goodrich FUS
Vergennes, Vermont
0 Kudos
Message 1 of 13

Try mass compiling all VI's.  It's probably a VI that you aren't even using (well, that's usually what I screw up when I get those kind of messages).


-Matt Bradley

************ kudos always appreciated, but only when deserved **************************

0 Kudos
Message 2 of 13
0 Kudos
Message 3 of 13

what are the VI files and can you please post up a step by step instructions list on how to resolve this issue. I'm under a major time contraint and i need to get this up and running in the next week.

0 Kudos
Message 4 of 13



Did you check to see if the KB Hunter posted resolves the issue?


If you're opening a project in a newer version of LabVIEW, then there's a chance the mass compile tool might work. It will open and save all of the VIs within a specified folder. The tool is fairly self-explanatory, and you can access it from within LabVIEW by going to "Tools --> Advanced --> Mass Compile..."


Good luck!

Caleb Harris

National Instruments | Mechanical Engineer |
0 Kudos
Message 5 of 13

This post is old, but still always actual because I got the same error.

Here is the solution:

in the build definition, change the destination folder. to c:\build


This problem occure because the number of character in the path of the VI is too long when the building tool copy the complete hierarchy to the destination build prior to build.


So if the original Vi has a full path of 250 character, then the building tools cannot save the copy of the vi at the build destination.


That simple... but the error from Labview say nothing about it... 😞



Message 6 of 13

Dear bseguin,


What do you mean by build definition? Where should I find this?

I have the same error and when I tried to track it down a function of uc480 SetColorMode is blinking.

Do you think your solution would work for me?


Many thanks.

0 Kudos
Message 7 of 13


When you prepare your build for .exe in your project, you can select the destination folder.

In that area, change it for a shorter path. I do not have LabVIEW in this PC. I cannot show you a picture.


0 Kudos
Message 8 of 13

Thank you very much for posting this. I wasted a whole day trying to solve this.


Using Advance TDMS was causing this error but only when I was using a higher number of channels!. When I reduce the number of analog, and other types of channels, It was working fine for some reason.


When I did what you suggested with the build and the mass compile to the same location, it solved the problem.



0 Kudos
Message 9 of 13

Hi, Can you please give me a detail explanation how you fixed the issue. I cannot get rid of the error.


Thanks much!


0 Kudos
Message 10 of 13