LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

fpga target VI won't compile

Solved!
Go to solution

I'm new to LabView FPGA and am currently trying to compile my VI on the target FPGA (a NI PXI-7842R).

The initial stage (which appears to be Labview generating the VHDL code) appears to execute successfully.

The next stage (which appears to be the actual compilation on the FPGA) runs for a short time, then reports an error following the completion of the PlanAhead stage.

The error message says:

 

LabVIEW FPGA:  An internal software error in the compile worker has occurred.

Error -61330 occurred at niFpgaCompileWorker_ProcessStatusPipe.vi:640001<-niFpgaCompileWorker_GetStatus.vi<-niFpgaCompile_Worker.vi:6460001

Possible reason(s):

LabVIEW FPGA:  An internal software error in the compile worker has occurred.

Access to the path 'D:\NIFPGA\corecache\F70DE3619E4B4D193B01053C274FD022E0C94A19.timestamp' is denied.

 

Any thoughts?

 

I'm using LabView 2013, the 2013 FPGA module, and Xilinx tools 14.4 on Windows XP SP3.

0 Kudos
Message 1 of 12
(3,892 Views)

Did you check the permissions on the directories mentioned?

 

Mike...


Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 2 of 12
(3,879 Views)

Yeah, forgot to mention that...

My account has r/w permissions to the directory.

Just to check, I also ran as admin, and got the same result.

0 Kudos
Message 3 of 12
(3,875 Views)

Have you been able to compile any FPGA VI's successfully before? Or can we compile other FPGA VI's and this is the only one that throws this error? If you cannot compile any FPGA code at all, then you have to do a repair install of the LabVIEW FPGA Module.

dK
0 Kudos
Message 4 of 12
(3,856 Views)

try to remove fpga module then install again

hi ?Q>

0 Kudos
Message 5 of 12
(3,851 Views)

I'll try to repair the installation and let you know how it goes...

0 Kudos
Message 6 of 12
(3,830 Views)

An update: I've repaired the Labview FPGA installation and the Xilinx compilation tools.

The error has changed!

Now, as soon as I attempt to compile (using the local compile server option) I receive the following error:

 

NI-Farm:  Farm server is not responding.  Be sure the specified hostname is correct, the server is running and configured to accept remote requests.

 

This is curious to me as I chose the local compile server option.

Nonetheless I attempted to configure the server to accept remote requests. I received the following error:


There was an error in connecting to the farm. Error: kNIFarmResultServerNotResponding LabVIEW Error Code: -123011

 

I'm beginning to think that I may need to do a clean install and try again.

 

The only other thought I have is that there may be an issue with my configuration: my LV installation resides on a separate hard drive from my operating system. Could this be an issue?

 

0 Kudos
Message 7 of 12
(3,802 Views)

Can you access localhost:3580 in the browser?

 

Make sure that you have the LabVIEW 2013 f1 patch installedhttp://joule.ni.com/nidu/cds/view/p/id/4358/lang/en

 

This could be related to an issue where the application web server service gets de-registered from a computer. This is directly addressed with the f1 patch.

Craig H. | CLA CTA CLED | Applications Engineer | National Instruments
0 Kudos
Message 8 of 12
(3,796 Views)

No, localhost:3580 isn't found.

I'll install the patch.

0 Kudos
Message 9 of 12
(3,789 Views)

OK, the patch installed correctly, and now attempting to compile returns an identical error to that reported originally... Smiley Frustrated

But I do have access to localhost:3582.

0 Kudos
Message 10 of 12
(3,780 Views)