Showing results for 
Search instead for 
Did you mean: 

fpga - invoke method run not working



I have an FPGA vi and then host vi (LabView 2013), in which I want to run the FPGA vi. I am using Open FPGA reference and then invoke metod.  When I choose abort and FPGA vi is running, it will stop. But if I want to start it (FPGA vi is not runnig) and use run, the FPGA vi does not start. Do I have to check/create something special in FPGA vi or should I do something special during the compilation?


Thanks a lot in advance



0 Kudos
Message 1 of 9

Hi Stanislava,


could you please attach the code example?




0 Kudos
Message 2 of 9

Thank you Nina for your reply.

Here is the piece of code, where I call the FPGA. Like this, it does not start the FPGA.

0 Kudos
Message 3 of 9

could you please attach the vi? I want to have a look on the configuration of the open FPGA reference function.


Thank you!

0 Kudos
Message 4 of 9

Original is too complex, so I made just this small one.

0 Kudos
Message 5 of 9



thank you for the vi.


So, I don´t know what you expect, the vi should do! Because you just start the fpga vi, but you don´t even read or write any data so you won´t see anything, even if it´s running. You could have a look on the LabVIEW example finder. There you will find several examples of how to read or write data, you get from the FPGA. I attached a picture of how you can find the examples.







0 Kudos
Message 6 of 9

But that is the problem. This does not start the FPGA. My FPGA is triggering cameras during acquisition of the data. I just want to run it when my program starts. But with this it is not running (at least, my cameras are not triggered). If I run it normally, that means I press run  button in the FPGA vi, everything is working. But that means that at first, I have to run the FPGA vi and than the acquisition program. For practical reasons I want to run just the acquisition program. I think I have to set something somewhere, but I still not figured out what and where.

0 Kudos
Message 7 of 9

So I figured it out. The FPGA did start run, but when I closed the reference, it also stopped. And I was using it after closing the reference. I did not realized, that it works like this(and also that nobody could notice, since I put just part of the code here). Thank you Nina, you inspired me to find the solution. 

0 Kudos
Message 8 of 9



sounds great. 🙂 Yes I am sorry that I couldn´t help in this case but I am glad that you could figure it out.


Have a nice week!

0 Kudos
Message 9 of 9