LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

error loading lvanlys.dll in Labview 64 bits

Solved!
Go to solution

I have installed labview 2019 64 bits in a new computer with a AMD Ryzen 3800x cpu. I get the error loeading lvanlys.dll whenever this dll is called (the dll is in its folder and the installation was default). If I run Labview 32 there is no such problem, but I need Labview 64 to have access to more memory.

 

In other computers also with Labview 64bits and intel cpu I do not get such error.

 

Is there any solution to be able to use Labview 64 bits?

Message 1 of 31
(4,122 Views)

What operating system and version are you using?

Tim
GHSP
0 Kudos
Message 2 of 31
(4,109 Views)

Thanks for the answer.

 

It is using Windows 10 Pro.

0 Kudos
Message 3 of 31
(4,079 Views)

I think that points to a toolkit?  If so, you'll need to install the 64-bit version of the toolkit.  Oops looks like part of the install.  Maybe LV 64-bits had an issue installing?

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 4 of 31
(4,064 Views)
  • Did you activate LabVIEW at full or higher or only "base"?
  • Are you running any unusual antivirus or security software?
  • ...
0 Kudos
Message 5 of 31
(4,049 Views)

Yes I have the full development system activated.

 

I am not running any antivirus. It is a clean installation of Windows 10.

 

I have tried to uninstall Labview 2019 64bit and install it again, but I get the same message. There are no error messages during installation, so I am not sure what else I can try.

0 Kudos
Message 6 of 31
(3,821 Views)

Does anybody have a clue why lvanlys.dll cannot be loaded? It is quite fustrating... I have also tried to change things in the Bios, without luck.

0 Kudos
Message 7 of 31
(3,259 Views)

When I use the dependency Walker on this dll I get many dependency errors. I guess it is not normal.

 

obarriel_0-1580840100057.png

0 Kudos
Message 8 of 31
(3,216 Views)

Is your BIOS updated to the latest rev?

 

-AK2DM

~~~~~~~~~~~~~~~~~~~~~~~~~~
"It’s the questions that drive us.”
~~~~~~~~~~~~~~~~~~~~~~~~~~
0 Kudos
Message 9 of 31
(3,204 Views)

I have updated the Bios and the result is the same. I have also tried to install other versions of Labview 64bits (e.g. 2018) but still the same.

0 Kudos
Message 10 of 31
(3,181 Views)