cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

[bug] get clipboard image fails in executable

Solved!
Go to solution
Highlighted

[bug] get clipboard image fails in executable

The 'Get Clipboard Image' method fails for images in built executables.

It works for text (you get an image of the text back).

In the runtime environment it works ok.

LabVIEW versions:

  • 2012
  • 2013

 

Test code:

GetClipboardImage.png

 

Regards,

 

Ton

Free Code Capture Tool! Version 2.1.3 with comments, web-upload, back-save and snippets!
Nederlandse LabVIEW user groep www.lvug.nl
My LabVIEW Ideas

LabVIEW, programming like it should be!
0 Kudos
Message 1 of 37
(2,571 Views)

Re: [bug] get clipboard image fails in executable

I dont think so, because in LV2011 it works

--------------------------------------------------------------------------------------------------------
Kudos are always welcome if you got solution to some extent.

I need my difficulties because they are necessary to enjoy my success.
--Ranjeet
0 Kudos
Message 2 of 37
(2,547 Views)

Re: [bug] get clipboard image fails in executable

You want to retrive data related to image or image?

--------------------------------------------------------------------------------------------------------
Kudos are always welcome if you got solution to some extent.

I need my difficulties because they are necessary to enjoy my success.
--Ranjeet
0 Kudos
Message 3 of 37
(2,543 Views)

Re: [bug] get clipboard image fails in executable

I want to get the clipboard image. If I run this code in the Development environment I get an image with the latest clipboard info.

If I run it (on the same) PC in an executable I get an image with the latest text data.

 

Ton

Free Code Capture Tool! Version 2.1.3 with comments, web-upload, back-save and snippets!
Nederlandse LabVIEW user groep www.lvug.nl
My LabVIEW Ideas

LabVIEW, programming like it should be!
0 Kudos
Message 4 of 37
(2,528 Views)

Re: [bug] get clipboard image fails in executable

I know for sure that it worked in LV 7.0, because I had an executable which copied the image from the clipboard using that method and displayed it in a picture control (in fact, I just dug it up and ran it now with the snippet you posted and it showed it just fine). Maybe it broke at some point along the way. I actually just tested it now in 2011 and it doesn't work there either when I build an EXE.


___________________
Try to take over the world!
0 Kudos
Message 5 of 37
(2,516 Views)

Re: [bug] get clipboard image fails in executable

check the RUN time property of all the components

--------------------------------------------------------------------------------------------------------
Kudos are always welcome if you got solution to some extent.

I need my difficulties because they are necessary to enjoy my success.
--Ranjeet
0 Kudos
Message 6 of 37
(2,509 Views)

回复: [bug] get clipboard image fails in executable

Ton,

How about now? I meet the same issue about Clipboard.Get Image node. 

 

http://forums.ni.com/t5/LabVIEW/Write-PNG-file-failed-when-build-exe-but-run-normally-on-the/m-p/254...

Colin
------------------
LV7.1/8.2/8.2.1/8.5/8.6/9.0/2010/2013; testing system development
Please Mark the solution as accepted if your problem is solved and donate kudoes


Home--www.colinzhang.net

0 Kudos
Message 7 of 37
(2,496 Views)

Re: [bug] get clipboard image fails in executable

The method is not on the 'not supported in thr RTE' list, here's the detail about this method:

Remarks

The following table lists the characteristics of this method.

Data type No return value
Available in Run-Time Engine Yes (Read/Write)
Available in Real-Time Operating System Yes
Remote access allowed

Yes

 

So I have a feeling that it should work, note that is works if the clipboard has text!

 

Ton

Free Code Capture Tool! Version 2.1.3 with comments, web-upload, back-save and snippets!
Nederlandse LabVIEW user groep www.lvug.nl
My LabVIEW Ideas

LabVIEW, programming like it should be!
0 Kudos
Message 8 of 37
(2,462 Views)

Re: [bug] get clipboard image fails in executable

Yes, i feel the same. 

Colin
------------------
LV7.1/8.2/8.2.1/8.5/8.6/9.0/2010/2013; testing system development
Please Mark the solution as accepted if your problem is solved and donate kudoes


Home--www.colinzhang.net

0 Kudos
Message 9 of 37
(2,441 Views)

Re: [bug] get clipboard image fails in executable

Why dont you store the array of pixels values to clipboard and later retrieve this only and show the image to user. This will solve the problem

--------------------------------------------------------------------------------------------------------
Kudos are always welcome if you got solution to some extent.

I need my difficulties because they are necessary to enjoy my success.
--Ranjeet
0 Kudos
Message 10 of 37
(2,434 Views)