cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

[bug] get clipboard image fails in executable

Solved!
Go to solution

Re: [bug] get clipboard image fails in executable

CAR 422317 discussed in this thread was fixed in  LabVIEW 2014.  For a more complete list of bugs fixed in LabVIEW 2014, check the LabVIEW 2014 Bug Fixes. You can download an evaluation copy of LabVIEW 2014 at http://www.ni.com/trylabview/ or if you have an earlier version of LabVIEW installed and an active SSP subscription, you will be able to download the latest version of LabVIEW through NI Update Service.

 

Regards,

 

Jeff Peacock 

 

Product Support Engineer | LabVIEW R&D | National Instruments | Certified LabVIEW Architect 

 

0 Kudos
Message 31 of 37
(627 Views)

Re: [bug] get clipboard image fails in executable

Hi Jeff-P

 

I tried it on LabVIEW 2014 SP1 and it still seems the CAR 422317 has not been implemented. (I didnt find it in the buf fix list that you posted as well)

The help documentation for the invoke node still mentioned the lack of support for run-time so I am sure it hasn't been fixed.

0 Kudos
Message 32 of 37
(572 Views)

Re: [bug] get clipboard image fails in executable

Hi Doradorachan

 

I was looking for more information related with that CAR number (422317), and it’s correct that this CAR number is not resolved yet. For that reason I recommend you that you can use this work around https://decibel.ni.com/content/docs/DOC-28436. That document is recommended in the CAR 422317 case.

0 Kudos
Message 33 of 37
(543 Views)

Re: [bug] get clipboard image fails in executable

Any updates on this solution. THe problem is I am trying to read an OLE obejct (chart created using NI office toolkit) from EXCEL into LabVIEW. I got it working with the clipboard get image method but it does not work in the built application. the .net solution discussed can only get images from the clipboard but not excel charts. Is the clipboard get image working in the latest labview version.

 

I have labview 2012.

0 Kudos
Message 34 of 37
(485 Views)

Re: [bug] get clipboard image fails in executable

You can see all the bugs that were fixed in LabVIEW 2015 at the below link, although from my search it looks like this issue hasn't been addressed yet. Your best bet would be to find a new workaround for this case or modify your application in some way to operate with the existing .net solution.

 

http://www.ni.com/product-documentation/52697/en/

0 Kudos
Message 35 of 37
(437 Views)

Re: [bug] get clipboard image fails in executable

I have the same problem in Labview2013

0 Kudos
Message 36 of 37
(245 Views)

Re: [bug] get clipboard image fails in executable

My Solution to paste the clipboard in a picture on the Frontpanel

 

clipboard.bmp

 

it works on runtime AND as an executable. 

 

(LabVIEW 2014 SP1)

0 Kudos
Message 37 of 37
(51 Views)