LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

abc

Hi there,

 

I am running two NI WiFi  CDAQ s 9191 at the same time.

 

In my first chassis I have NI 9234 with which I am acquiring BP data.

 

In my second chassis I have NI 9401 from which I am trying to supply my pressure sensor and solenoid valve to close leakage in system.

 

However, when I run my program, I get the following message (pasted at the end).

 

I think this is something simple to fix? I am using the WiFi modules for the first time. Any help would be greatly appreciated.

 

I am pasting my code for your reference.

 

Best regards,


Saif

 

-----ERROR MESSAGE-----

 

Possible reason(s):

 

Device cannot be configured for input or output because lines and/or terminals on this device are in use by another task or route. This operation requires temporarily reserving all lines and terminals for communication, which interferes with the other task or route.

 

If possible, use DAQmx Control Task to reserve all tasks that use this device before committing any tasks that use this device. Otherwise, uncommit or unreserve the other task or disconnect the other route before attempting to configure the device for input or output.

 

Device: cDAQ9191-1775C70Mod1

Digital Port: 0

Lines: 4

 

Task Name: _unnamedTask<F2>

 

-----ERROR MESSAGE-----

0 Kudos
Message 1 of 28
(3,184 Views)

Sorry, I had forgotten to give a proper subject line. Therefore, reposting...

 

----

 

Hi there,

 

I am running two NI WiFi  CDAQ s 9191 at the same time.

 

In my first chassis I have NI 9234 with which I am acquiring BP data.

 

In my second chassis I have NI 9401 from which I am trying to supply my pressure sensor and solenoid valve to close leakage in system.

 

However, when I run my program, I get the following message (pasted at the end).

 

I think this is something simple to fix? I am using the WiFi modules for the first time. Any help would be greatly appreciated.

 

I am pasting my code for your reference.

 

Best regards,


Saif

 

-----ERROR MESSAGE-----

 

Possible reason(s):

 

Device cannot be configured for input or output because lines and/or terminals on this device are in use by another task or route. This operation requires temporarily reserving all lines and terminals for communication, which interferes with the other task or route.

 

If possible, use DAQmx Control Task to reserve all tasks that use this device before committing any tasks that use this device. Otherwise, uncommit or unreserve the other task or disconnect the other route before attempting to configure the device for input or output.

 

Device: cDAQ9191-1775C70Mod1

Digital Port: 0

Lines: 4

 

Task Name: _unnamedTask<F2>

 

-----ERROR MESSAGE-----

0 Kudos
Message 2 of 28
(3,170 Views)

Hi Vhha,

 

do you also use 9401 channel as digital input? I think the error is caused by mixed DI and DO task in one port.

0 Kudos
Message 3 of 28
(3,149 Views)

Hi taov,

 

Thats what I thought. But no, I only use it for D/O striclty.

 

Any ideas how to stop this from happening?

 

Cheers,


Saif

 

 

0 Kudos
Message 4 of 28
(3,137 Views)

Is it possible to merge those two DO task to 1 DO task? And also, try to used line 0 and 1, because based on the manual book, 9401 channels are grouped in two port. One containing channels 0 - 3, and the other containing channel 4 - 7.

0 Kudos
Message 5 of 28
(3,126 Views)

Hi taov,

 

Any hints on how I could do it? I am a little new to Labview.

 

Thanks!

 

Saif

0 Kudos
Message 6 of 28
(3,106 Views)
Delete one of your DO task. On another DO task double click on it to show DAQ Asistant window. In DAQ Asistant window, click add channel button (button with + symbol) and then choose another channel you want to add to the task.
0 Kudos
Message 7 of 28
(3,099 Views)

Thanks Taov!

 

Will try and let you know.

 

Cheers,

 

Saif

Message 8 of 28
(3,090 Views)

Hi Taov,

 

I tried to do what you suggested but it gave me error.

 

Besides, as my program gets complicated, I want to do more that just sending 5V output constantly. At times, I want to send 5V and then 0V as some conditions change (from the same channel). Such as switching ON/OFF a pump.

 

I tried this post:

 

http://digital.ni.com/public.nsf/allkb/0495B7D5E2345DF386257730007EFD17

 

I tried to include my code in the flat structure sequence.

 

Please see attachment.

 

But still does not work!

 

Cheers,


Saif

0 Kudos
Message 9 of 28
(3,050 Views)

Hello Saif,

 

What error code are you getting? Can you please post a screenshot of it?

 

Thanks,

Joel C

National Instruments

0 Kudos
Message 10 of 28
(3,004 Views)