LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VRML

Solved!
Go to solution

Hi metadeth

I attached 4 file

Please open file 1.wrl in 1.v1 and

Please open file 2.wrl in 2.v1 and

 

regards 

 

0 Kudos
Message 21 of 56
(1,818 Views)

Hi!, Naser1363 and Metadeth.

 

You said you managed to represent a 3D model into LabView using the 3D Picture Control loading a VRML file, don't you? I tried to do exactly that several months ago but I finally gave it up, because I couldn't get the view of the 3D model from a VRML file. I posted a message in another topic where I commented one of the problems I noticed this VI had: "Load VRML" didn't seem to recognize decimal units of the values of geometric and property parameters of the VRML file. You can see this message here:

 

http://forums.ni.com/ni/board/message?board.id=170&thread.id=260517

 

I've recently upgraded to LabView 8.6, and I supossed this problem would be fixed, but it still remains. At least, I tried to do the same, but it also doesn't work now.

 

Could you help me? How did you do that?

 

Thanks in advance

 

Regards,

Francisco

0 Kudos
Message 22 of 56
(1,753 Views)

Hi Dear Francisco

 

I don't understand your problem.please tell me again.But I want to tell you how do you make your VRML file?For example if you make it with Solidworks you must save your file with VRML97 not VRML1.Because I know Labview 8.2 an 7.1 dose not support VRML1.I don't have a Labview 8.6.

please tell me your problem again if I can I will help you.

 

Best regards

 

Naser
0 Kudos
Message 23 of 56
(1,743 Views)

Hi, Naser.

 

Thank you for your fast reply. I know what you mean about VRML version. I obtain the VRML file through Solid Edge: I create a 3d model, and then I "save as" VRML file. I think the version is correct, because I can read the VRML file by the Notepad and in the first row appears "#VRML V2.0 utf8 Solid Edge VRML Export V1.2". That means that is the correct version (VRML97 is the same than VRML 2.0).

 

I think it is better to send you a file so you can check if it works or not. I send you the following:

 

eslabon.vi: LabView program

 

Block Diagram.jpg: snapshot where you can see how the program looks like

 

Solid Edge model.jpg: snapshot of Solid Edge software and the model I created

 

eslabon.wrl: VRML file created by Solid Edge from the model

 

Control Panel running.jpg: snapshot of the Control Panel while it is running; there is nothing in the 3D Picture Control

 

When you get the files, you only have to open "eslabon.vi", select the file "eslabon.wrl" and run the program.

 

I hope you can help me.

 

Thanks again.

 

Regards,

Francisco

0 Kudos
Message 24 of 56
(1,734 Views)

Hi Dear Francisco

 

I don't have a Labview program now.But I can open our WRL file with  V-Realm Builder software.

I understand your VRML file is not VRML97.

I think it is reason for your error.

Please save your file again with VRML97.

IF you cant save it with VRML97 please send your Solid Edge model then I will save it to VRML97.

Please save your Solid Edge model with a good Suffix to i can open it with Solidworks.

I think if you save it with (.igs ) I will can to open it inSolidwork

 

Best regards
0 Kudos
Message 25 of 56
(1,729 Views)

Hi Dear Francisco

Plesae excuse me i forgot i can open WRL file with solidwork.

But i dont acess to solidwork now.

Do you can wait me for next two days?

Best regards

 

Naser

0 Kudos
Message 26 of 56
(1,725 Views)

Hi, Naser, again.

 

Well, actually I have also Solidworks. So, in Solidworks, I load the model created by Solid Edge, then I save it like VRML file (selecting VRML97 option) and it also doesn't work in LabView with the "Load VRML File.vi", but now it shows an error: "This scene is missing expected nodes or contains nodes that LabVIEW does not support.".

 

So, I send you the following:

 

eslabon.par: model in Solid Edge

eslabon.SLDPRT: model in Solidworks

eslabon SW.wrl: VRML file I get through Solidworks

 

Thank you very much. And don't worry, I'll wait what is needed to solve that.

 

Regards,

Francisco

0 Kudos
Message 27 of 56
(1,731 Views)
Sorry, I forgot to attach the files.
0 Kudos
Message 28 of 56
(1,730 Views)

Hi Dear Francisco

I will try to solve your problem if I can.

But i don't access to Labview tow next days.

If you can please wait.

Best regards.

Naser

0 Kudos
Message 29 of 56
(1,710 Views)

Hi Dear Francisco

 

I forgot  i want to tolld you please save your Labview file that I can open it with Labview 7.1

 Because I think I can't open your file with Labview 7.1

 

Best regards

 

Naser

0 Kudos
Message 30 of 56
(1,705 Views)