LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VRML

Solved!
Go to solution

Hi,

 

I ran the VI with highlight execution and the program didn't behave strangel. All the values seem to pass over as expected (even through the object doesn't show up)

 

Nandha: If you still have a working version or any version of the VI (working/not working), can you please post back? I would like to test that.

 

Francisco: What object am I supposed to be seeing? Also I see you are using a number of property nodes, can you create an example that loads only the VRML file? I say this so that we can narrow down the problem itself. 

 

Do either of you have a screen shot of what the final image is supposed to like in 3D picture control?

 

I am going to more troubleshooting at my end in the meanwhile.

Warm regards,
Karunya R
National Instruments
Applications Engineer
Message 51 of 56
(1,786 Views)

Ok, here you go

I have succesfully run the program once again. I used the melon2.wrl model (the one that Francisco gave me and i modified it). I put some screen shot of the working program and attached the program with the vrml file.

 

Please observe the translation and scale very carefully, The scale is (X,Y,Z) = (1,1,1) and the translation (-0.01,0.01,3.95).

If you change the translation by .01 value, the object will go out of the screen.

 

Let me tell you something, I really think that it is not a loading error, its just about bad translation and scale. Other than that is all about VRML file setting (lighting, background sky, etc).

-Just a student-
Download All
Message 52 of 56
(1,764 Views)

Hey guys.

 

Updated version, let me rephrase what i said before.

Its actually not also about the object but also the camera of the scene. This time i made it look like the solar system example (the melon rotates in its y axis).

I just change the camera position and not changing the object translation or scaling.

Please see the attached image and file. And remember please pay attention to the camera position, and target.

Hope this solve the problem.

Btw i am using labview 8.5 evaluation software.

 

 

 

-Just a student-
Download All
Message 53 of 56
(1,762 Views)
EUREKA!!

First of all... thank you all, specially Nandha, who give me important feedback information, so I was able to find out my problem... because that was, a problem with my computer configuration...
 
I followed Nandha's examples and instructions... but nothing still appeared in the "3D Picture Control"... but I noticed that on Nandha's snapshot there was "0.04" written in the camera position control. Not "0,04", but "0.04". I also remembered what I realized months ago, when I tried to do exactly this, and I supossed that "Load VRML.vi" didn't recognize REAL values, but only INTEGER values (I was able to load a 1x1x1 cube, but if a tried a 1.5x1x1 cube, again appeared a 1x1x1 cube on the image display)... So, I went to my computer configuration: Windows Start-->Settings-->Control Panel-->Regional configuration, and in "number" settings, I changed "," for "." in decimal separator, and viceversa in thousand separator...I closed and reopened LabView, and it appeared!!
 
So, now I can see any VRML model I load. Well, is difficult to set the camera position, but at the end, I get it. But, there's another little problem I'd like to tell you, and maybe you know how to fix it: depending on the camera position, most of times, it seems to be there are two "virtual planes" that cover the VRML model when it's set in certain positions. These "virtual planes" are in the front and the back of the camera view, parallel to each other. Do you know why? I send you the VI and some snapshots.
 
Thank you for all.. that's good, I feel better now, hehe...
 
Regards,
Francisco

Message 54 of 56
(1,730 Views)

Awesome job Nandha and Francisco is getting this worked out!

 

 

Warm regards,
Karunya R
National Instruments
Applications Engineer
0 Kudos
Message 55 of 56
(1,707 Views)

Glad i could help, bro

 

Hi porras, i cannot open your vi, its in 8.6 version. Please save it to 8.5.

And don't forget. " Gymmy kudos pleaaaase" 😛 hehehe

-Just a student-
0 Kudos
Message 56 of 56
(1,692 Views)