LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

VRML

Solved!
Go to solution

Hi, Karunya.

 

Thanks for your help. But I don't understand you clearly.

 

 In issue number 138552 it's said that the "error in" terminal has been removed from the "Load VRML.vi" in Labview 8.6, so if I had used this block in a program in version 8.5, I should apply this.

 
This is not my problem, but I'm not able to load a VRML file because either there's no error and no 3D model is shown in the 3D Picture Control, or appears the following error:

 

"LabVIEW:  This scene is missing expected nodes or contains nodes that LabVIEW does not support.
Method Name: Scene:Read Scene File"

 

So, do you mean that there's no solution for this problem yet, and it is currently being investigated?

 

Then, why it's said in this tutorial http://zone.ni.com/devzone/cda/tut/p/id/317 (section Importing a 3D model from file) that it's possible to do?

 

I hope you can help me.

 

Thanks in advance.

 

Regards,

Francisco

Mensaje editado por Porras
0 Kudos
Message 41 of 56
(1,900 Views)

Hi francisco

 

Problem solved (at least on my site).

As I suspected, it has something to do with lighting and background of the vrml file.

 

Actually from th beginning, your file was already loaded. Its just that it can't be seen. I have no idea about the error you mentioned before that Labview gave some error message. But anyway, I am using labiview 8.5 and these are the files. Use my program example to view.

 

I changed melon.wrl to melon2.wrl. The changes I made are: Background { skyColor 1 1 1 } to Background { skyColor 0 0 0 } and remove all definition about directional lights. Please compare the files. And reset the transformation to 0 position before running the program. You will see your melon very small, and change the Z translation to bigger value, and voila you'll see your melon bigger.

 

If there is any issue about not able to load the file (Labview message error) maybe it has something to do with the version you use.

-Just a student-
0 Kudos
Message 42 of 56
(1,889 Views)

Hi francisco

I think you want to modeling a robot and move these links.

I model a robot with VRML and move these link.

But I think it be better you use "Labview 3D picture control"

 

Regards

 

Naser

0 Kudos
Message 43 of 56
(1,877 Views)
Hi, all.

Thanks again for the supported help.

But my problem still remains. Nandha, I opened your file and loaded the models you attached me, and nothing still appears in the "3D Picture Control" window. In this case, there's no error, but nothing appears. I also try to change translational atributes, but it's useless... nothing, nothing, nothing...

I have tried to represent a red cone and a 3D model together in the same window, and I have changed several geometric parameters. I also managed to set the camera view to a fixed initial point, so that when I run the program it begins at the same position (for doing this I copied part from "solarsystem.vi" in LabView help). I also tried to copy all the properties from the "SceneObject" that belongs to the cone to the "SceneObject" that results from loading the VRML mode. The model I try to run is that one that Nandha sent me back (with background parameters equal to {0,0,0}). I attach you the files.

So, please, try to run this VI on your machines and tell me if you can see the cone together with the VRML model. I saved it like version 8.5.

Regards,
Francisco
0 Kudos
Message 44 of 56
(1,857 Views)

Well, in the last attached file there was a little error... I placed a "Clear all transformations" block after making a transformation (translation + scale) to the cone, and another one to the VRML model.

 

I attach you the corrected file.

0 Kudos
Message 45 of 56
(1,855 Views)

Hi Francisco,

 

I just ran your VI. I was able to see the cone in the picture 3D control and also be able to move it around it when the program is running. I have attached a screen shot of it working.

 

It is possible that it is just bad copy of the VI. I suggest that you copy the contents of the VI over to a new one and see if you still have the same issue. 

 

Let me know if you have any further questions.

 

Warm regards,
Karunya R
National Instruments
Applications Engineer
0 Kudos
Message 46 of 56
(1,828 Views)

Francisco,

 

A few more things

 

  1. Do you see the same behaviour is multiple computers?
  2. Have you tried different versions of LabVIEW?

If this doesn't work, it might be a bad installation of LabVIEW, though I doubt that is the case.

 

Let me know what happens!

 

Warm regards,
Karunya R
National Instruments
Applications Engineer
0 Kudos
Message 47 of 56
(1,826 Views)

Hi, all again.

Karunya:
well, I also can see the red cone. This is not the problem. In the VI are generated two objects: (1) the red cone (creating in Labview using a simple geometry) and, (2) an object I created and I imported like VRML model, through "Load VRML.vi". The problem is that the red cone should appear near the VRML model object, because the two objects has the same transformation and the two objects has the same origin, but, as you noticed, it only appears the red cone, and there's no VRML object in the 3D Picture Control.


Thanks all again... hope to find out soon the solution...

Regards,
Francisco

0 Kudos
Message 48 of 56
(1,814 Views)

HI

I cant help you because you dont use "Read.VI" and "Write.Vi".

Sorry

 

regards

0 Kudos
Message 49 of 56
(1,803 Views)

Its really frustrating, actually.

 

Now, even my example that i gave you earlier is not working in my computer. So, after i tried to run your program (which it was working for a while, and now its not), and then even my own program cannot work, just blank on the screen, no VRML not even a cone. I wonder what happened.

 

Porras: Have you tried using ASE file, it was a geometric file from 3DSMax, I was more sucessful in using this format instad of VRML. Less stress. But there are some tricks that need to be pulled from exporting the ASE file in 3DS, can't remember what though.

-Just a student-
0 Kudos
Message 50 of 56
(1,798 Views)