Showing results for 
Search instead for 
Did you mean: 

USB-serial not found by NI-VISA

Hi, I am a new poster here; I have been using Labview for about a year.

I have a new USB-Serial converter that I cannot get VISA to see.

Windows installs the converter fine; when I use the NI-VISA driver wizard to create a new driver, I get an Error -1073807343: VISA could not find resource, even though it then shows up in Device Manager as an NI-VISA USB device.

NI-MAX does not see the port. 

I have scoured this forum for several hours and cannot find a solution.  Could someone please provide advice?  Thanks!!


I am using:

Windows 7

LV 2009 Student Edition

NI-MAX 5.0.0f1

NI-VISA 5.03

0 Kudos
Message 1 of 23

Does the USB-serial convertor show up in Windows device manager as a Com port?


If so, the com port should be able to show up in MAX under Devices and Interfaces, then Serial and Parallel.


I don't know why you would be trying to use the NI-VISA driver wizard.

0 Kudos
Message 2 of 23

You will most certainly have to try and undo the damage you did by using the VISA wizard. Use a system restore point. I also don't understand why you would do anything like that. You just can't make things up like that. All that you needed to do was install the windows driver from the vendor.

0 Kudos
Message 3 of 23

I tried creating the NI-VISA driver because it wasn't showing up in MAX, even though it was showing up in Windows device manager.  Never thought it would be a big problem.  I haven't had any trouble before seeing devices.  I'll try the system restore.


0 Kudos
Message 4 of 23

In order for the VISA wizard to work, you would have to uninstall the driver that makes it a com port. And then, even with the VISA wizard inf file installed and recognized, you would not be able to use it as a com port. You would need to use very low level USB RAW commands. A problem with a virtual com port not appearing in MAX is not unheard of. Some USB-RS232 converters just don't work. What is the brand? Do you know what the USB chipset is?

0 Kudos
Message 5 of 23

OK, I have retored to the point before I created the VISA driver.  The Windows driver is installed; it shows up as COM7 in Device Manager, but still doesn't show up in MAX. 

This is a Black Box IC199A-R3 USB-Serial converter with FTDI chipset. 

0 Kudos
Message 6 of 23

If I remember correctly, the FTDI chips generally work.  I think it is the Prolific chips that have problems sometimes.


What shows up im MAX under Devices and Interfaces >> Serial and Parallel?  Do you not see a Com7 in there?

0 Kudos
Message 7 of 23

No, just LPT1.  Would the "Create New Port.." help?

0 Kudos
Message 8 of 23

I don't know.  I've never needed to use that menu choice before.  The USB-serial converters I use just always show up in device manager and MAX.  They just work.

0 Kudos
Message 9 of 23

Crap.  OK, thanks.  I'll let you know if I have any success; if it doesn't work I'll try another one.  The Prolific one I tried earlier didn't work, either.


Thanks for all the help!!!

0 Kudos
Message 10 of 23