LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

USB-serial not found by NI-VISA

I've always had good luck with ftdi as well. You can try downloading the latest driver from their website.

 

What version of NI-VISA do you have installed and what is your OS?

0 Kudos
Message 11 of 23
(2,870 Views)

@Bricko wrote:

Crap.  OK, thanks.  I'll let you know if I have any success; if it doesn't work I'll try another one.  The Prolific one I tried earlier didn't work, either.

 

Thanks for all the help!!!



We use the Tripp-lite Keyspan USB-serial adapters and they work fine and are recognized in NI-MAX.

0 Kudos
Message 12 of 23
(2,870 Views)

I am using:

Windows 7

LV 2009 Student Edition

NI-MAX 5.0.0f1

NI-VISA 5.03

 

I just noticed that when I click on "Serial & Parallel", under Resource Name it says "Internal Max Error".  Maybe that's my problem - I'll try reinstalling/updating MAX?

0 Kudos
Message 13 of 23
(2,865 Views)

For sure you'll want to uninstall/remove any drivers you created with the VISA driver wizard.  Make sure you have the latest version of the manufacturer's driver installed on the machine.

 

The device should come up as a COM port under Ports in Device Manager.  It also shouldn't have a yellow "!", be disabled, or be an "unknown device".  Drivers should be loaded, and Windows should be communicating with it.

 

Once you reach this point, open MAX.  Expand Devices and Interfaces, expand Serial & Parallel, and that COM port should be in the list.  It should also read "The device is working properly", and "Device Enabled" should be checked.

 

I have one FTDI device here, installation was as straight-forward as any other USB-232 adapter I've used.  Got a Prolific adapter on my computer now, haven't had any problems with it.  Used to use IOGear GUC-232A's extensively, those worked fairly well.  Most of the PCB's I design get a SILabs CP2102 chip for anything that needs serial, I've had good luck with those but they're not without their problems.  Once theyr'e set up and the driver's attached the device works great.

 

Strangely, I've had the most problems with NI's serial adapters.  Not sure if it was a ground loop in the system or what, but the end result is the VID/PID of the device would change and the device would be unusable since the driver wouldn't recognize it.

0 Kudos
Message 14 of 23
(2,861 Views)

@Bricko wrote:

I just noticed that when I click on "Serial & Parallel", under Resource Name it says "Internal Max Error".  Maybe that's my problem - I'll try reinstalling/updating MAX?


MAX and NI-VISA would be what I'd do.

0 Kudos
Message 15 of 23
(2,859 Views)

If MAX has an issue there is a procedure to can go through to fix a currupted MAX.  I had to do this twice.  Not sure if this issue qualifies as currupt.

 

Here is a link. 

 

currupt MAX db

 

older link

 

older one

-------
Mark Ramsdale
-------
Message 16 of 23
(2,848 Views)

In my experience, simply uninstalling/reinstalling MAX is a much more foolproof and effective way of fixing MAX database and internal errors. 

0 Kudos
Message 17 of 23
(2,843 Views)

The uninstall program tells that I have to uninstall pretty much everything, including LV itself, in order to uninstall MAX.

I uninstalled VISA & reinstalled progressively newer versions, with no effect.  How did you uninstall MAX?  I am faced with the proposition of uninstalling & reinstalling everything.

0 Kudos
Message 18 of 23
(2,828 Views)

Add/Remove Programs, "National Instruments software".  There's a list of all the NI components installed, find MAX in there and uninstall it.  I think there's a "dependencies" window that comes up, but there should be an option to uninstall it anyways.  Then just reinstall from the discs or download.

 

0 Kudos
Message 19 of 23
(2,815 Views)

Bricko:

If, after all the uninstalling and reinstalling is complete you find that MAX still does not see your device, you may have an issue similar to one I had back in early June this year.  For some reason, some serial devices will claim COM ports and the Windows registry marks them as "reserved".  This can lead to situations where the COM ports end up at some high number for newly installed devices and some device drivers may not support those COM port numbers (or may become confused by them).  I have attached three links here which describe how to clear the reserved status via the registry.  Each link describes the problem and shows what to do, it's really a matter of style as to which method of describing how to solve the problem you prefer.

 

I added all three links just in case you want to review the issue in detail before proceeding (again, if the uninstall / reinstall does not work).  Note that although two of the three articles describe the problem as a Windows XP or 2000 issue, I first ran into it on a Windows 7 professional machine.

 

Phantom Serial Ports in Windows

 

Resetting COM Port Assignment

 

Clearing or Resetting COM port Assignments

 

I hope this helps.

Bill

GCentral
0 Kudos
Message 20 of 23
(2,794 Views)