LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Test Stand app builder

My apologies, I thought you just meant the sequence file and code modules. Which LabVIEW Operator Interface are you using? You should be able to attach the sequence file and your three vis and I can try to create the build myself to make sure there is not something wrong with those.

Brandon Vasquez | Software Engineer | Integration Services | National Instruments
0 Kudos
Message 21 of 27
(609 Views)
I use my own LV.exe to call the TS.seq file in question. I guess you can use any that you have. Again, that part works just fine. My .exe calls the TS.seq file (attached) which runs and calls three vi's in an LV.llb (also attached). The first action step  finds the first vi but returns a LV error (reported earlier in one of these posts, error18002) saying the vi is not executable. We know the labview engine works because my LV.exe runs. We know the TS engine works because the TS.seq runs. After the error the LV.exe continues to run and it can be exited normally.
 
This is in LV 7.1 and TS 3.1
 
Again, the vi.llb shows up in the image file correctly on the source computer. The icon for the .llb file shows up on the target computer as an "unknown file type" icon. You can't open it or use it. If you try to open it windows says it does not know what to open it with etc etc. The target computer has to be completely free of any LV or TS software to start with before this installation.
Download All
0 Kudos
Message 22 of 27
(595 Views)
I build this distribution and was unable to get the same results. What are you including in your installer? Are you including the correct LabVIEW Runtime Engine? The error you are getting is a LabVIEW error which occurs when an executable has a VI with a broken arrow (an error that causes the VI to not run). None of your VIs have this, however it is possible your Operator Interface may, please make sure all VIs in your OI are able to compile before building into and executable.

Brandon Vasquez | Software Engineer | Integration Services | National Instruments
0 Kudos
Message 23 of 27
(580 Views)

When you say "operator interface" I assume you mean the vi.exe I built (and did not send you) and included in the TS install files which calls the TS.seq,  It runs, so it can't possibly have any broken vi's. It runs before it is built into an executable and it runs after it turns into an .exe and it runs on the target computer. The entire thing works as it is supposed to on the source computer so there cannot be any broken vi's.

The vi's that are called by the TS.seq (that I did include last time) are not used by the compiled main vi (the one that calls the seq). The only choices I had in TS 3.1 for LV engines are "full featyred LV interface (no rev specified) and LV engine 6.1. Since my main LV works I have to assume that whatever engine is installed is correct.

The installer has the ts.seq file, the three vi's (included automatically "insert code modules"), ini files for the main vi. It appears that the installer automatically includes the vi.llb because I did not include it and it shows up.

0 Kudos
Message 24 of 27
(576 Views)
Yes, I do mean your LabVIEW VI you created. TestStand has two different ways to run a sequence, one is the sequence editor which is what you use to develop your test sequences and then your operator interface, which is what is used on the test floor by operators and does not allow you to edit sequences. One thing about your "LV.exe", did you create this from scratch or work off one of the provided OIs? It is always highly recommended that you work off of one of the provided OIs instead of creating your own from scratch. Compare you LV OI with the provided OIs (Simple OI should be fine) and make sure you are doing everything in your OI that needs to be done in TestStand.

Something else you mentioned could be the problem, you said you are including the Runtime Engine 6.1, you are assuming since your OI works correctly that these other VIs should work correctly as well. This is not true, if your OI is compatible with 6.1 of LabVIEW, then it would work just fine. However, your VIs you have attached are 7.1 compatible, you yourself said you are using LabVIEW 7.1. If your deployment does not have LabVIEW Runtime 7.1, this would cause the VIs to be unrunnable.

There are various KnowledgeBase articles as well as Developer Zone documents on our website about deploying TestStand sequences and installers. I can not find direct links right now as parts of our website are currently down, however if you search on ni.com for deploying teststand (obviously once the pieces of the site come back up). This should give some more information that is definitely good to look at.

Brandon Vasquez | Software Engineer | Integration Services | National Instruments
0 Kudos
Message 25 of 27
(572 Views)
I don't know how many other ways I can say the OI works perfectly on the source computer and it works on the target computer. Unless there is something strange going on, the OI calls the seq as it should (on both computers) The sequence runs as it should but the vi's are not recognizeable on the target computer. I tried another experiment. This does not involve TS at all. I got a fresh computer (never had LV or TS on it before). I put LV 7.1 on it, this included engine 6.1, 7.0 and 7.1. All vi's worked normally and appeared normally. I then removed LV, leaving all three engines. The .llb's and individual vi's no longer were recognized by the computer just as with the other computer used as my original target computer. No sequences, no test stand and no OI's just LV 7.1.
 
0 Kudos
Message 26 of 27
(565 Views)
gtb,

I'm just trying to help troubleshoot the problem, since I was able to deploy these with no problem, there are only a few possibilities for why this is not working.

A) Your OI has a problem (since you have said this is not the case, you can rule it out)
B) Your deployment installationg does not include everything it needs (are you including your Station Options and other configuration files? This is all covered in our documentation online and in the TestStand Reference Manual about deploying your TestStand tests)
C) You do not have the correct engine (which you originally said you had only 6.1 Engine, but now you are saying 7.0 and 7.1 as well, before you made this statement, this seemed like the likely choice)

I'm trying to help you find the source of the problem, when you said



@gtb1234 wrote:
The only choices I had in TS 3.1 for LV engines are "full featyred LV interface (no rev specified) and LV engine 6.1. Since my main LV works I have to assume that whatever engine is installed is correct.

It seemed like a no brainer since you were developing in 7.1, but now you are saying you have 7.1 Runtime (I'm not sure where the descrepency on this was, but you originally said it was not included).

Now, here is the direct link to the document I have talked about the past two posts.

http://digital.ni.com/public.nsf/allkb/EE3382373D209449862570A5006572F0

If I could give you a direct link to the help topic in your TestStand Reference Manual, I would, but hopefully my directions on how to get to it are enough. It is in Chapter 14, the entire chapter covers important information about TestStand deployment. To get to this, go to the TestStand Bookshelf and there is a link to this Reference Manual. If you can not find it, you can download it from here

http://digital.ni.com/manuals.nsf/websearch/001CAEC82BFF505386256D470060788D

Since you have already ruled out A and C, it leads me to believe that B is the only possible reason for this problem. Please go through these documents and make sure you are doing everything correctly. I know Jonathan pointed you to both of these documents on January 22nd, but something with your deployment is not correct and causing this problem. Go through these documents, verify you are doing everything you need to do in your deployment, include everything you need to include and follow the document verbatim. Once this is done, there should be no reason your sequence and VIs do not work.

Brandon Vasquez | Software Engineer | Integration Services | National Instruments
0 Kudos
Message 27 of 27
(553 Views)