LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Test Stand app builder

I would like to find out how to create a stand alone application out of the following scenario without either the LV
editor or the TS editor being present on the computer. (LV 7.1, TS 3.1, XP Pro) As far as I know you can't make an executable out of the TS software. It has to be called from a LV app.
 
1) I know how to use the LV Application Builder on strictly LV aplications.
 
2) I have a LV application as the main program. It calls the main TS sequence. It just has a tab control on the front
panel which uses active X controls to plug the TS responses into the LV controls. I have a Sequence File Tab, Execution Tab and a Report Tab as well as a button to control which TS execution model to run.
 
3) The TS software calls many LV vi's (not the main LV vi).
 
4) It has been debugged and works.
 
 Thats it.
 
 How can I build an installable app (without the editors)?
 
I'm guessing that there are built in tools in both editors (besides the LV App builder) that need to be run in a
certain order to make this work.

Thanks.
GTB
0 Kudos
Message 1 of 27
(2,738 Views)
GTB,

TestStand supplies you with a tool called "Deploy TestStand System". You should use this one. For proper usage, you have to create a TestStand-workspace including all needed files.
Regarding the LV VIs, you have several choices, but one is imho the best: create a LLB including all needed modules. Configure the TestStand-steps appropriate to this setting and include the LLB in your TS-workspace.
Now use the deployment tool from TS and propably you want to create an installer. Make sure that you include the TS Engine as well as the LV RTE (and perharps additional drivers for hardware).

hope this helps,
Norbert B.
Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 2 of 27
(2,713 Views)

Hi GTB,

After you have created your TestStand sequences, it is best to use TestStand Deployment Utility.  The tool is quite simply to use as the Deploying TestStand Systems KnowledgeBase and Chapter 14 of the TestStand Reference Manual give you lots of assistance on using this utility.  Chapter 14 gives you step by step instructions and information on properly deploying. 

Overall, the steps that are mentioned in those documents are:

1) Create a TestStand workspace (File
» New Workspace File).
2) Create a new TestStand project and add it to the workspace (right-click your workspace file and select Insert New Project into Workspace).
3) Add your TestStand sequence files.
4) Right-click on your workspace and select Insert Code Modules. This step will grab all your code modules (LabVIEW VIs) and add them to your workspace.
5) Launch the TestStand Deployment Utility (Tools
» Deploy TestStand System)

You don't have to create any LLBs before using this utility.  Just add your sequences, insert your code modules and then go through each tab in the deployment utility and you should be good to go.

Let us know if you have any more questions.

Best Regards,


Jonathan N.
National Instruments
0 Kudos
Message 3 of 27
(2,706 Views)

TO; Johnathan N

When I tried to "Insert Code Modules" I got an hour glass for about 10 to 15 seconds and a message which said "no code modules were inserted". I tried several times. Sometimes the message comes up immediately sometimes delayed as stated. The vi's are in the same directory as the seq file (which inserted OK) or directories under that directory. They are all .llb's (they were this way from the beginning). All vi's entered with "specify module" were entered using a relative path in the seq file.

gtb

0 Kudos
Message 4 of 27
(2,692 Views)

Hi GTB,

If your LabVIEW step's code module is a VI inside of a LLB, when you insert code modules inside of your workspace, it should find your VI and place it under the Code Modules folder in your workspace. However, it might have a red X next to your VI as it appears this is because its inside of an LLB. I tested this out myself and I did see the red X.  However, when you open the deployment utility and analyze your workspace (Distributed Files tab), it correctly finds the VIs in the LLB.  I would check and make sure that your VIs are found in this tab as this is the true indicator if TestStand can find your files. 

Also, you can right-click on your workspace file and select Insert Code Modules which will insert all the modules for all the sequence files you have included in your workspace.

Hope this helps!

Best Regards,

Jonathan N.
National Instruments
0 Kudos
Message 5 of 27
(2,685 Views)

I get no red X's , no vi's, absolutely nothing, just the message I indicated in the previous post.

The only thing I can think of is that I have installed TS ver 3.5 evaluation and LV8.2 Eval and am using the code from TS3.1 and LV7.1

gtb

0 Kudos
Message 6 of 27
(2,677 Views)
Hi gtb,

Is it possible to post the sequence and LLB that you are having trouble with. I can build a workspace here and use your sequence and code module to see if I have problems.

Best Regards,
Jonathan N.
National Instruments
0 Kudos
Message 7 of 27
(2,675 Views)
It's far to large to post. I'll write something simple from scratch just to get this to work. If I am still having problems I can then post  that instead.
 
Thanks
gtb
0 Kudos
Message 8 of 27
(2,667 Views)

Johnathan,

OK, The workspace file window has three panes, upper left, upper right and lower. If you right click in the upper right (file and SC Status) you get the option to "insert code modules". This is where it does not work. You get the same option in the upper left pane (tree view) which does work.

Another situation popped up during this effort. Attached is a very simple sequence file (TS 3.5) and a LV 8.2 vi which should be placed in C:\TEMP Run the sequence with the input to the vi checked as default ("c:\test.txt"). Then run it with default unchecked. Then put any letter but "T" or "t" as the first charactor in the file name and run it again both default checked and un-checked. Run the TS sequence by selecting the only step and then "run selected steps."

gtb

 

 

Download All
0 Kudos
Message 9 of 27
(2,646 Views)
Hi gtb1234,

As far as the workspace issue of not being able to insert code modules, I saw the same behavior when I right-clicked in the right-pane of the workspace windows. I am not sure why that's happening so I need to check in on that.

Your second issue is that you need to send in "C:\\test.txt" verse "C:\test.txt". TestStand uses C style strings in which one backslash could represent an escape character. Putting two backslashes fixes your issue.

Best Regards,

Message Edited by Jonathan N on 01-30-2007 08:57 AM

Jonathan N.
National Instruments
0 Kudos
Message 10 of 27
(2,638 Views)