LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Steps for Running and Calibrating the Stepper Motor in LabView

Hi Friends,


Currently, I am working on the Stepper motor + Encoder system for my application.
Stepper Model is as Follow: STM23Q-3AE 


Commands Type : A. Motion Command B. Configure Command C.  Servo Command D. Communication command E. IO command


Command Mode: A. NV B. Read Only C. Write Only D. Intermediate


Initial Problem:
I tried to follow the initial as step as :
a. Create basic program on the LabVIEW to check the response of the motor. Program is quite simple and easy to follow. ( I enclosed the file)
b. I started with the Configure Command: Well it worked! , I started initially with the Configure Command Like ME(Motor Enable) and Later on with AC (Accelerate motor 25 rev/sec). But even with my basic command, I cant able to see any motion on the motor shaft. Its like stall or something I am not sure of it.
c. Is there any basic way to check the motor is working properly. any suggestion will be really helpful.

 

Thanks.
Kind Regards

0 Kudos
Message 1 of 26
(785 Views)

With the "AC" command, you're changing the acceleration rate, but not the actual speed.

 

Try maybe "CS" (change speed), "JE" (jog enable) and "JC" (jog commence) or similar?


GCentral
0 Kudos
Message 2 of 26
(734 Views)

Hi, 

 

Tried using all the possible command suggested but didnt seen any motion on the motor shaft. I can see the response in the Reading buffer but no motion, its really frustrating! any suggestion will be really helpful

 

13.png

 

0 Kudos
Message 3 of 26
(717 Views)

Well if all of the commands are being received and acknowledged but none of them are working.

 

I would say you need to check your hardware, but after a quick look at the website and I have to ask:

 

Have you ran the SCL Configurator?  Maybe you have to configure it first?

 

Have you tried using the SCL Utility  to get it working to eliminate any hardware issues?

 

Also there is some sample code available on the website, take a look at it and see if you are doing it right.  

========================
=== Engineer Ambiguously ===
========================
Message 4 of 26
(709 Views)

Hi,

 

Thanks for your earlier reply, I was looking to the SCL Configurator, But I didn't understand when I try to run  my LabVIEW script with the com port 1,it work well, when I try to choose the com port 1 in the SCL configurator, it was missing not sure what's going out there. I check the device manager and MAX Labview panel, it shows me the COM port1. I have directly connect my cable to the NI PXle-1078(Labview DAQ). Is there any issue with the com port?

 

14.png

0 Kudos
Message 5 of 26
(690 Views)

It's hard to tell from your picture but here's a couple things to think about...

  1. Only one program can have "control" of a VISA resource like a Com port.
  2. If LabVIEW has a VISA session open for that port, no other program will be able to access it. (Remember to close your VISA sessions)
  3. It works both ways. If another program has control of the com port LabVIEW can not access that port.
========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 6 of 26
(686 Views)

Thanks for your response,

 

I just check the motor with the self drive test, and i still find that motor shaft is not moving. I think there is serious issue with the hardware. 

a. It show that it is connected

19.png

 

b. it show that it is trying the drive test

20.png

c. It is responding all the commands in SCA utility as well as in my LabVIEW program

21.png

0 Kudos
Message 7 of 26
(655 Views)

Hi,

 

I tried to use the SCL configurator and the stepper motor is working, It is responding to all the commands in SCL terminal (utility) and there is shaft movement. But later on I tried my LabVIEW code, now its not working, I am not sure, why it is showing error. Earlier it was having the response with the motor but no shaft movement. I need to design my application in LabVIEW . I just use the SCL configurator for my drive test. any suggestion?22.png

0 Kudos
Message 8 of 26
(622 Views)

Are you sure your serial port settings are correct?  You didn't wire anything into the Serial Port Configuration which means it will use the defaults of 9600-8-none-1.

 

Are you sure the termination character is a carriage return and not a line feed character?

0 Kudos
Message 9 of 26
(612 Views)

Yea Raven, Port are correct I am bit surprise last day, I was using the same program and it was responding to my all configure commands except the motion one.  So I use the SCL configurator to test my system (to check if there is any issue with the motor) and it work. Later on I tried to use both configure and motion command now, none of them working.

 

I am thinking that I connected the other device to the same port, does it affects the measurement of current device ? I restarted the system and both the device and still I am having using with response. The termination character is return. 

 

 

 

 

0 Kudos
Message 10 of 26
(606 Views)