Showing results for 
Search instead for 
Did you mean: 

Source Distribution discards VI Description



I support a program mostly written in LV2011. Part of it includes a plug-in architecture which we deploy using Source Distribution builds in the project. The main application loads up the VI Description information to assist the user with configuring the specific plugin.


This worked great in LV2011


We are moving to LV2015 right now, and I have discovered that the source distribution build removes the VI description in LV2015. I have tried all the different settings I could find, both in the VI and in the Build Properties, but always the VI Description is removed. The one case where the VI description remains is if the VI being distributed was last saved in an older version of LabVIEW.


As another data point, if I load that LV2015 VI into LV2016, the same thing happens. It will build with description until I save the VI to 2016, then the description is gone.


I'm looking for community help to see if this is a known bug, or more importantly, if there is a known fix.


Perhaps there's a more correct method for distributing plugin VIs that I just don't know about?


Until then I'll have to manually edit my built distributions to re-apply the VI Descriptions. That's an hour every build I won't get back 😕


The attached zip demonstrates the issue.




0 Kudos
Message 1 of 6

I have not tried that but another approach is to use the Project "Save for Previous" and in the drop-down choose the current version.


It is worth a shot...



Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 2 of 6

Oddly enough this almost works.


I created a simple test project in LV2011, it builds fine there.

I moved it to LV2015, it builds fine there, until I save the VI into LV2015 then, no VI Description

Save for Previous to LV2015, didn't help

Save for previous to LV2014, then the VI description comes back


At first I thought I had solved this yesterday. I updated to LV2015 SP1 f10 and I was able to build a distribution from an old project that might have started as long ago as LV8.6

But then I tried again today and while that old project that has migrated up through the versions still works, new projects behave as described above.

I was thinking maybe it was some strange issue with my 2015 installation, but I put 2016 on a different machine and it behaves the same.


It couldn't be that this is a bug in at least these two versions of LabVIEW?


Is there a preferred method for distributing VIs to be called dynamically at run time? I'm afraid I'd have to do a lot of rework to the code that calls these dynamic VIs if I change to some other method.

0 Kudos
Message 3 of 6

@Bauer_CT wrote:


It couldn't be that this is a bug in at least these two versions of LabVIEW?

If it's there, it's there until they fix it. If they don't know, it's very likely that it's not fixed!


Some bugs lingered on for >5 versions...

0 Kudos
Message 4 of 6

I guess it's more like "am I the only one who uses VI Description from my source distributions"

0 Kudos
Message 5 of 6

Hello Bauer,


I reproduced the behavior you described in LabVIEW 2015 and LabVIEW 2018. I believe this is a bug, therefore I have filed the Corrective Action Request (CAR) # 702708. You can check on future patch/software releases if this issue gets fixed.


Thank you very much for taking the time to report this issue.




Message 6 of 6