Showing results for 
Search instead for 
Did you mean: 

Send email on labview using the Gmail Server (TLS)

While I haven't had any luck freeing up the attachment file by closing the references, I have been able to free it up by using AttachmentCollection Dispose().  I'm not sure if this will do anything for potential memory leaks, but it does allow other programs to access the attachment file after the email is sent.



Message Edited by minitor on 12-08-2008 09:56 PM
Message 31 of 114



i'm still getting "Error 1172", and when i ping it gives me 'request timedout'.


can you help me fix it.



0 Kudos
Message 32 of 114

An error from what, doing what? You're replying to a post that's many months old, and you haven't indicated what you're doing or what your code looks like.


Many servers will block ping request, but for now, is not. If you're getting a request timeout when trying to ping then it can be (a) the server wasn't available for some reason; or (b) your routers were blocking the ping packet; or (c) one of the many routers between you and was "off-line" temporarily.

0 Kudos
Message 33 of 114

when i run this VI it gives me the Error and i don't know why, and i saw one of your prevoius replies and you said try to  ping




0 Kudos
Message 34 of 114
When I tried it the email was send and received. Does this occur with only Gmail?
0 Kudos
Message 35 of 114

    I appreciate if you could send a PDA version of

0 Kudos
Message 36 of 114
Eric V
National Instruments
Applications Engineer
Certified LabVIEW Associate Developer

"I'm a Ramblin' Wreck from Georgia Tech and a helluva (NI Applications) Engineer!"
0 Kudos
Message 37 of 114



Thanks for the help.


I was not successful in running the SMTP example provided for PDA Mobile,though I used the same POP and SMTP settings to send mail through my native mobile e-mail client.


I got following error message from E-Mail server:


"553 Sorry, that domain isn't in my list of allowed rcpthosts."


Listing the arbitration between PDA SMTP  VI and e-mail server.


Message to server :

  1. HELO
  2. MAIL FROM:<>
  3. RCPT TO:<>
  4. DATA
  5. To:
    Subject: Project details  Test.
  6. QUIT

 Response from Server:

  1. 220 ESMTP.
  2. 250
  3. 250 Sender accepted.
  4. 553 Sorry, that domain isn't in my list of allowed rcpthosts.

 I would really appreciate if any of you could interpret this arbitration and let me know waht the issue is.Attaching the VI I used for this communication.


Thanks in advance,

Manu Mohan

0 Kudos
Message 38 of 114

Hi Manu Mohan,


Is your email server secure?  The SMTP VIs in that example do not allow you to connect to a secure SMTP server.

0 Kudos
Message 39 of 114


"This server requires a secure connection(SSL)" option in my outlook settings is disabled.


Does that mean my server is not a secure SMTP server ?




0 Kudos
Message 40 of 114