Showing results for 
Search instead for 
Did you mean: 

Running LabVIEW 2012 Application builder get message about missing LabVIEW 2013 media

Go to solution

I am trying to make an installer using LV 2012 (Latest version for which I have a license-- Installed from Developer Suite 2013, latest disks I have.)\


I am asking the installer to include Run Time Engine 2012 SP1 f5-- Only choice presented to me for a 2012 RTE


When I Try to build an installer, I get a message asking for a LV 2013 media path, which I don't have...


Any ideas on why this is happening or how to get around it?

0 Kudos
Message 1 of 14

You do have LV 2013 media.  You sad you installed from Developers Suite 2013, which is LV 2013 media.  Just insert that DVD.


Kelly Bersch
Certified LabVIEW Developer
Kudos are always welcome
0 Kudos
Message 2 of 14

Hi Kelly:


Actually, the media I have is what I used to install LV2012, and LV 2012 is the latest version listed on that media.  Perhaps it was early enough in the year that LV 2013 was not yet included in DS 2013? My disk is 2013DS1, and the readme file lists a december 2012 version of LV2012 SP1 as the latest version of LV on the disk.


And when I put that same disk into the drive in response to the prompt, I get a message saying that the disk is a valid installation media, but for the wrong version-- its looking for a LV 2013 disk, not a DS disk.   I know this seems a little strange but that's what is happening.


At any rate, thanks for the reply, I appreciate your effort, but in this case, but I think the problem is a little more complicated. 


(If I get no other suggestions, I'll try downloading LV2013 onto my c: drive, and without trying to install it redirct to it when the message pops up.-- But I'd love to hear from someone who has had the same problem and has a definitive answer.)


Again, thanks and best regards, Louis


0 Kudos
Message 3 of 14

Greetings Louis_Manfredi


Can you confirm what version of the Application Builder you have installed in your computer? Is this problem present when you try building an installer on other projects? It is possible there was a faulty installation of your LabVIEW which may require a repair or reinstall. Please let us know.


Warm Regards, 

Luis J.
Applications Engineer
National Instruments
Message 4 of 14

Hi Luis:


Thanks for getting back to me.  I am running LV2012SP1  12.0.1f5(32 Bit)   I'm not sure if the app builder has a separate version number, or how to find that number if it does.


Everything was loaded from DVDs labelled "NI Developer Suite 2013" Version DS1.


When I installed the software, the system asked me I I wanted to install updates over the net, which I did.  Might be an issue there, since the support package is expired-- perhaps it gave me some updates, but not all? 


I don't have any other projects on this computer-- I've been away from LV for a while, and a former employer hired me on a contract basis to update a program I wrote a while back, so this is the only project I have on my system right now.  (I could write a trival application and see if that works too if that would be a useful troubleshooting tool.) 


BUT...  I tried the trick I suggested I might do in my last post, I downloaded LV2013 installer, unzipped it but didn't launch it, and pointed to it when the app builder asked for the media path.  This seems to have worked-- I was able to build an application.  But a few peculiarities remained:

(1) the app builder gave me the choice of requiring XP SP2, but when I ran the installer on the target machine running SP2, I got a message saying that it needed SP3.  (Got SP3 onto the target, and then installer worked and program ran.)

(2) After first run of the program on target machine, it slowed way down-- unusably slow.  After some exploring, I found that the Windows Service routine for automatic updates was taking 100% of my processor time.  (disabled service routine, now the program runs fine.)


So I've got a working system, but still curious about the cause of the problem, and whether either of the above peculiarities are related to original problem.   And most importantly whether the approach I took to working around the problem was a good one, or if there's going to be issues with the installer on other machines down the road.  So I'll be happy to provide any further info if it helps, and very grateful for you getting back to me on this.


With best regards, Louis

0 Kudos
Message 5 of 14

Hi Louis_Manfredi,


I am glad to hear you have a functioning work around to this issue.  I am interested in whether you are using any toolkits attached to LabVIEW 2012 SP1 in your application?  Or is it just the environment itself?  It shouldn't be asking you this if it is the environment itself, application builder wouldn't of updated to a newer version it would be the version that was attached to LabVIEW 2012 SP1.

Peter T
Applications Engineer
National Instruments
0 Kudos
Message 6 of 14

Hi Peter:


Thanks for getting back to me.


The application uses a low pass filter, (NI_AALBase.lvlib:Butterworth which might be part of a signal analysis toolkit?


It also uses a variety of DAQmx stuff, but I don't think that is toolkit, is it?


But other than that, it is pretty much its all plain vanilla LabVIEW.


Best regards, Louis



0 Kudos
Message 7 of 14

Hi Louis_Manfredi,


So reading through this I can't seem to think why this error is happening if you only installed off of DS1 because it didn't have anything from LabVIEW 2013 on that disc and our programs don't update by platform level just individual patches.  What DAQmx are you using?   Also can you post a screen shot of License Manager with the software tab expanded?  Please expand the LabVIEW 2012 tab to.

Peter T
Applications Engineer
National Instruments
0 Kudos
Message 8 of 14

Hi Peter:


Sorry for the long delay getting back to you, I've been off on other projects for the past few.


I have NImax 5.4.0f0 on my computer.  Other than that, I don't see any stand-alone DAQmx-- mostly I configure the DAS equipment programatically from within LabVIEW. 


Attached is a screen shot of the NILM display.  You'll note that there's a LV2013 in addition to the LV2012 SP1.  Not sure why the 2013 shows up in the LM-- don't recall ever loading it, not even a demo version, and what I'm using is the 2012 SP1. 


Since my last post, a few other peculiarities with the app builder-- last week I had a period where it would only run the application builder once to make an installer.  After that I'd get an error message of some sort (I neglected to make a note of the exact message-- If I see it again I'll make a note of it.)  In order to run the app builder a second time, I had to shut down the computer & reboot.-- it then let me run the app builder one more time, then reboot needed to run it a third time.


I also had a peculiarity where when I ran the installer on the target machine, it would give a "no software will be installed" message.  I am pretty sure that this was unrelated to the other problems-- A simple user error, that I wasn't updating the revision number of the exe application, so when the installer went to install on the target it thought the version on the target was the same as the version that I wanted to install?  But I mention it in case it has some bearing on the problem.


Client testing the application reports that it is ready to go, so I'll be attempting to build on final (for this release) clean installer version later today-- I'll let you know how that goes.


Thanks for your attention, and again, appologies for the delay in responding to your questions.


Best regards, Louis

0 Kudos
Message 9 of 14

The f5 patch also contained some RTE fixes so would not have been on DS2013 DS1  The earliest media the 2012 PS1 f5 patch for the RTE could have shippedon was DS 2013 DS2 


Does that clear it up?

"Should be" isn't "Is" -Jay
0 Kudos
Message 10 of 14