LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Running LabVIEW 2012 Application builder get message about missing LabVIEW 2013 media

Solved!
Go to solution

Hi All:

 

In my last post I mentioned that I can only run the app builder one time per boot of Windows...  I've repeated the problem, this time taking the effort to grab a screen shot of the error message, which is attached.

 

Hi Jeff:

 

Interesting information.  I'm not sure it exactly clears up the mystery, but it may provide some insight.  When I check my version number in "About LabVIEW..." it does report 12.0.1f5. But I have never installed anything later than the 2013 DS1 version on my machine.  Your comment suggests that this is an impossible situation-- if we can figure out how it was that the impossible happened, it might lead to better understanding of the problem.

 

 

Best regards to all, Louis

 

 

0 Kudos
Message 11 of 14
(627 Views)

You got the update via download through the update service (So it should be in C:\ProgramData\National Instruments\Update Service\Installers\ somewhere)

 

Try C:\ProgramData\National Instruments\Update Service\Installers\NI_20131210_1019\Updates\LabVIEW Run-Time Engine 2012 SP1 (64-bit) f5 Patch 12.1.5


"Should be" isn't "Is" -Jay
0 Kudos
Message 12 of 14
(619 Views)

Hi Jeff:

 

Seems very likely that's what happened-- I don't find exactly the file you mention, but I do find "1640961457 - NI LabVIEW 2012 SP1 f5 Update.xml" in ~\National Instruments\Installation Logs, and I recall when I did the installation of DS 2013 SP1 I let the installer look for updates on the web during the installation.

 

===

 

I'm suspecting now that my installation of LV is badly corrupted--  When I attempted to build an installer after my last post in this thread, the application builder claims to have sucessfully build an installer, the installer appears to run successfully on the target machine, the installer is about the right size (~200 MB) to make a full installer including RTE & other support files, but when I launch the resulting application, I get reports of missing library files.

 

I think that clearing out everything NI, and starting from scratch with a clean install might be the best bet.  Anyone have thoughts on this?

 

And I seem to recall the last time I had to do a complete uninstall there was a trick-- simply running windows unistallers on everything NI wasn't quite enough, there were a few files or registry items which hid out on the machine and needed to be manually wiped away. Is my memory correct on that score, and is it still true?

 

Best regards, Louis

0 Kudos
Message 13 of 14
(603 Views)
Solution
Accepted by topic author Louis_Manfredi

Hi Folks:

 

I'm cleaning up loose ends here.  Just for the record, uninstalling LV completely, reinstalling it from DVD, but refusing updates solved my problem. (Not sure if it was the original installation from disk that was bad, or the update, but everything seems fine without the update, so no need at this point to put it in.)

 

Also, and maybe this is fixed in later versions, but a good thing to note since I don't think it is too clear in the documentation--- Seems like even if you don't intend to have your user access max, if your program calls daqmx vi's, your installer needs to include max.

 

Had the problem solved late last year, but I've been busy, so just getting around to cleaning up my email inbox now...

 

Thanks to everyone for the suggestions and help on this issue.  Problem Solved.

 

Best regards, Louis

Message 14 of 14
(582 Views)