LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem creating Executable

Hi all,

I have developed an application using XControls in LabVIEW 2009. I have a problem creating the Executable. I get this error which is attached to the post. 

I have doubts regarding the vi's in the project files that i need to add in the Start up VI's. Since i have too many vi's in XControl. 

Can anyone help me how to go about this.

Sorry if i am not clear about anything

Regards,
KM
0 Kudos
Message 1 of 4
(2,874 Views)

But there is clearly specified reason - you have recursive path to VI, and this path is too long. Check your settings for exe Build Specification - somewhere in Destinations, most probably, you have cross-link between paths, what causes recursive creation of paths.

Message 2 of 4
(2,858 Views)

Hi,

Thanks for your time,

I did try to reduce the path size. Now that the path is not too long. I am still not able to build the executable.

Regards,
KM
0 Kudos
Message 3 of 4
(2,818 Views)

I am not sure - b/c I can not recreate your issue, but: for building of exe you have Source File Settings tab. There you can setup, whether to delete or not Front Panel of VI for exe. By default, for all subVIs (which are not dynamic), Front Panel is removed. And, if this VI uses some Property or Invoke nodes, VIs in the exe can be corrupted. Maybe it causes the problem in your case too - b/c there is something wrong with Invoke Node inside some VI. Just try to change settings for that VI (deselect removing of Front Panel). It's just an idea, I'm not sure, that this is a reason - but you can try...

0 Kudos
Message 4 of 4
(2,713 Views)