LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview 2014 hangs at startup

Solved!
Go to solution

Hi,

 

I recently installed the Motion drivers from my 2014 'Device Drivers' DVD and my installation of Labview 2014 now hangs just after it starts up. It gets to the "Welcome to Labview" popup and then it locks the mouse cursor out and sits there taking 5% of the CPU.

 

I am on Windows 8 64bit. All of my files are local i.e. I'm not using any mapped network drives.

 

Eventually it crashes with the following error:

 

LV crash report.png

 

I've tried:

 

1) Repairing the installation via my installation media.

2) Uninstalling all NI software via the Control Panel, rebooting and re-installing via my installation media.

3) Uninstalling all NI software via MSIBlast, deleting all NI registry keys, rebooting and re-installing via my installation media.

4) Uninstalling all NI software via MSIBlast, deleting all NI registry keys, rebooting and re-installing latest LV 2014 SP1 from the NI website

 

Nothing seems to fix this and now I am truly up the creek.

 

Any help would be greatly appreciated.

 

 

0 Kudos
Message 1 of 14
(4,083 Views)

I assume that you sent the reports to NI.

I assume this is 32bit LabVIEW, correct?

Did you install everything in the default locations?

Are you running any unusual antivirus or personal security software?

Are you sure your computer is free of malware?

0 Kudos
Message 2 of 14
(4,073 Views)

Hi, yes 32bit labview in the default location. I submitted the report as well.

0 Kudos
Message 3 of 14
(4,069 Views)

Sorry, I added two more questions to my post above. (see also)

0 Kudos
Message 4 of 14
(4,053 Views)

Hi, sorry I posted before your edit.

 

I'm running AVG Internet Security. I've tried disabling it but the problem persists.

 

I have malwarebytes (full version) which runs daily. I just ran another scan and no malware is found.

0 Kudos
Message 5 of 14
(4,045 Views)

Disabling all antivirus/antimalware software makes no difference.

 

 

0 Kudos
Message 6 of 14
(3,997 Views)

After uninstalling and reinstalling all of the device drivers, LV hangs at startup, then crashes but now gives this error

 

LV_mnu_loop.png

 

I tried deleting the file but the problem persists.

 

The LV log is attached.

0 Kudos
Message 7 of 14
(3,983 Views)

Hopefully NI will chime in after looking at the crash report, but clearly there is something terribly wrong.

 

Do you have any unusual software installed?

Is the computer otherwise stable?

Have you tried scanning the HD for errors?

How about clearing all the temporary folders, etc.

 

Sorry, this is a case for NI.

0 Kudos
Message 8 of 14
(3,962 Views)

Nothing unusual, no. It's a relatively new Windows install (~4 months). Except for this one problem, everything else is stable.

 

I will scan the HD for errors and clear temporary folders and see what happens.

 

Other than that I'll see if I can raise a ticket with NI tomorrow.

 

I really appreciate your help, altenback. Thank you.

 

 

0 Kudos
Message 9 of 14
(3,955 Views)
Solution
Accepted by sinkovich

I have fixed it. I have no idea why this would work but here's what I did.

 

- Reinstalled LV 2014. Problem was still there.

 

- Uninstalled everything via the control panel.

 

- Deleted the following registry trees

 

HKEY_CURRENT_USE\Software\National Instruments

HKEY_LOCAL_MACHINE\Software\National Instruments

 

- Reboot

 

- I found I still had a C:\Program Files (x86)\National Instruments directory, so deleted that.

 

- Installed LV 2013 which then worked.

 

- Uninstalled LV2013 via control panel. Deleted the C:\Program Files (x86)\National Instruments directory again. (Not sure if this was necessary but I wanted to see if an earlier version worked)

 

- Reinstalled LV2014 latest version via download.

 

Problem is now fixed.

0 Kudos
Message 10 of 14
(3,930 Views)