Showing results for 
Search instead for 
Did you mean: 

LabVIEW 2012 used to hang at shutdown, now hangs at launch ("Initializing menus")

Go to solution



I'm running Windows 8 64-bit, and have LabVIEW 2012 32-bit (12.0f3). I started using it a few days ago, and was never able to shut down LabVIEW properly. I could close my projects, but when I then tried to exit LabVIEW from the home screen, the GUI simply stop responding, and I'd have to forcibly kill it. Then, I installed the latest VIPM, and noticed that I can't shut that down properly either (I believe VIPM is implemented in LabVIEW?). None of my non-LabVIEW-based programs have this issue.


Then, I tried to install OpenG from within VIPM, which launched LabVIEW itself. However, that hung at "Initializing menus".


I'm not sure if VIPM had anything to do with it, but now, I'm unable to start LabVIEW altogether. Even after restarting my machine (using the Restart option, not Windows 8's Hybrid Boot), LabVIEW would hang at "Initializing menus". Task Manager shows 0% CPU activity, and LabVIEW had only taken ~20MB of memory.


What could be the cause, and how can I fix it?




Certified LabVIEW Developer
0 Kudos
Message 1 of 14

Another symptom: I attempted to uninstall all National Instruments software, and it runs into an error at: "Currently Removing NI LabVIEW FPGA Xilinx 13.4 Tools - Part 9 : Part 1 of 497."




The system cannot find the file specified.


Certified LabVIEW Developer
0 Kudos
Message 2 of 14

Ok, I:

  1. Uninstalled ALL National Instruments, JKI, and IVI software.
  2. Rebooted
  3. Manually deleted residual NI, JKI, and IVI files/folders
  4. Cleaned the Windows registry of NI, JKI, and IVI entries
  5. Rebooted
  6. Checked Task Manager to ensure that no NI service eluded deletion
  7. Installed LabVIEW 2012 from the NI Developer Suite DVD (LabVIEW only -- no other components)
  8. Rebooted
  9. Launched LabVIEW

LabVIEW launches now, but I'm still unable to shut it down properly... 😞 One day it will probably refuse to launch too.

Some help please?

Certified LabVIEW Developer
0 Kudos
Message 3 of 14

My guess would be the FPGA Xilinx tools are the root of your troubles.  See here for NI product compatability with Windows 8.   Did you turn off fast start?

"Should be" isn't "Is" -Jay
0 Kudos
Message 4 of 14

Thanks for replying, Jeff.


When installing, I deselected EVERYTHING, and selected only "Ni Development Suite Core" -> "LabVIEW 2012 (English)". So, I have no other modules, no FPGA support, no drivers, no patches, no Xilinx tools.


Anyway, I tried disabling fast startup, but LabVIEW still hangs at exit.



Does LabVIEW come with a diagnostics tool/troubleshooter?

Certified LabVIEW Developer
0 Kudos
Message 5 of 14

I would suggest working closely with your local NI support team.  Most of LabVIEW has been tested out on Win 8 and is "Under Normal Support"  (That means they will fix bugs found - not quite the same as "no known issues exist")


I'm sorry but, you are on the (B)leading edge here... New OS's are usually that way.  figuring out what Microsoft really did is a lot more trouble than reading about what they thought they did. 


I even coded a bug onceSmiley Wink

"Should be" isn't "Is" -Jay
0 Kudos
Message 6 of 14

Will do. Thanks for the tip!

Certified LabVIEW Developer
0 Kudos
Message 7 of 14
Accepted by topic author JKSH

It was my antivirus that seemed to be interfering! Disabling Avast! Free Antivirus 7.0 made LabVIEW behave properly.


Has anyone encountered something similar before?

Certified LabVIEW Developer
Message 8 of 14

I have exactly the same config and the same problem with Windows 8 and Avast 7.
Disabling Avast, I managed to close the labview's window.
Can you open examples ?

More information here

0 Kudos
Message 9 of 14

No, I couldn't open examples with Avast! running.


Avast! + LabVIEW = Hang at shutdown, Hang at examples

Avast! + LabVIEW + VIPM = Hang at startup


I haven't tried running examples with the antivirus disabled yet. I can try when I get home

Certified LabVIEW Developer
0 Kudos
Message 10 of 14