LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Instrument assistant still output 0.0 without serial input, where is the trigger? - Noob question

Solved!
Go to solution

Guys bear with me, I am a other PLCs and VB/C programmer, there are old paradigms still locking my head.   :womansad:

 

Refer attached vi. After i disconnected the serial input, the instrument assistant still outputs 0.0 at its terminal at regular interval about 1 hz. Now how come the inst assistant still output 0.0 without a serial input trigger? There must be a timer some where.... but I looked everywhere there is no timer including by opening the front panel of the instrument assistant. I look at the while loop block and the VISA block etc, there is no timing settings. :womanmad:

 

So my question is, if there is no serial input to the instrument assistant, what is the object/setting that triggers the instrument assistant to still output 0.0 at a regular interval?Where is the object/setting?

 :smileyvery-happy:

Advance thanks 

0 Kudos
Message 1 of 3
(2,239 Views)

NEVER POST A VI WITH AUTORUNNING

 

The 0.0 is probably the default value (NaN would have been better), I find it kind strange that you get every second a reply, if I convert the express VI to a normal VI (with right click->open front panel) the timeout is 3000 ms so I would expect a response every 3 seconds.

 

Ton

Free Code Capture Tool! Version 2.1.3 with comments, web-upload, back-save and snippets!
Nederlandse LabVIEW user groep www.lvug.nl
My LabVIEW Ideas

LabVIEW, programming like it should be!
Message 2 of 3
(2,227 Views)
Solution
Accepted by topic author sunflower2772
Huge huge thanks! I can sleep tonight! Muahahahahahha!:smileytongue:
0 Kudos
Message 3 of 3
(2,221 Views)