Showing results for 
Search instead for 
Did you mean: 

Installer does not work on different PC

Go to solution

I have created an installer, which is working on my PC. I have used Labview 2022 Q3 (32-bit) on a Windows 10 pc.

When I try to install the application on a NUC (windows 11), the installer does not work.

The error is:

.\source\MetaInstaller\ConfigInfo.cpp(2506): InstallerError 10007

Fatal Error. Unable to load a resource DLL. 

Unable to load the custom resource file "File path" because Windows error 126: The specified module could not be found. while attempting to load the resource DLL "same file path"


When I searched for the file, I found the file at this location.

I tried to install the software with an error log according to Creating an Error Log File for a Software Installation - NI

But this does not generate a error log.

0 Kudos
Message 1 of 9

What is a "NUC"?  Why not install Windows 10 (which has a "sure" history of working with all "recent/current? versions of LabVIEW?  [In the "old days" (pre Q3), many seasoned LabVIEW experts waited until the SP1 version was released to install the "latest LabVIEW" ...].


Bob Schor

0 Kudos
Message 2 of 9

Running Executables or Installers on Different Windows Versions

Installers and executables are only guaranteed to work on the operating system they are built on.  For example, a Windows 10 installer or executable may not work as expected on a different Windows version (e.g. Windows XP, Windows 8, or Windows 7).

0 Kudos
Message 3 of 9

A NUC is a kind of pc. You can google for pictures if you want. Currently, I installed Windows 10 on the NUC, but it didn't work. I was able to install the program with the same installer on a different PC today. 

0 Kudos
Message 4 of 9

Does this also apply for building on windows 10 enterprise and installing on windows 10 pro?

0 Kudos
Message 5 of 9

Well there's nothing special about a NUC, I would guess it's Windows 11 that is causing you grief. I can't say that I have tried installing an executable built on Windows 10 on to a target machine running Windows 11. But I have built on Windows 11 and installed on Windows 10 without issue.


Try rebuilding your installer.

=== Engineer Ambiguously ===
0 Kudos
Message 6 of 9
Accepted by JulianNL

Julian, I am assuming that you have installed software that depends on 2022 Q3 (23.5) released products which likely included a hidden package called "NI ADE Deployment Support" (package: ni-mdfsupport version 23.5). This package is something that LabVIEW relies on to create non-NIPM based installers.


There is a component in that package that has a dependency on the VC 2015 Runtime and it incorrectly changed its linking to the VC runtime from static to dynamic. Since Windows 11 does not include that runtime with its base OS, an installer built by LabVIEW would not find the VC runtime it requires to run.


To workaround this issue right now, you should be able to manually install on the Windows 11 system the Visual C++ Redistributable for Visual Studio 2015 (32-bit: vc_redist.x86.exe).  Please let me know whether that mitigates the issue for you.


Once NI releases any of our 2023 Q4 (23.8) software, installing almost any of those will update that 23.5 package.

Scott Richardson
National Instruments
Message 7 of 9

this works for both windows 10 and 11.

0 Kudos
Message 8 of 9

Julian, thank you for confirming!

Scott Richardson
National Instruments
0 Kudos
Message 9 of 9