LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Executable File Not Reading Channels on Different DAQ Chassis

Hello All,

 

I have an executable file that I have built that opens and runs on a computer with a different DAQ board than that of the original LabVIEW VI. (original file done on NI 9174 and the executable file is running on NI 9188)

 

When the file is running, even though all of the equipment is plugged in, I am getting no readouts. 

 

There could be two reasons for this:

 

1) The application cannot run on the NI 9188

2) I setup the input channels on the computer with the NI 9174 and have not setup the same channels on the computer with the NI 9188.

 

Do I need to use MAX to setup the same channels, with the same names as the original LabVIEW VI, such that the executable file will recognize those and start receiving data?

 

I thought the point of the exe file was that it could be run on any computer with just the Run-Time engine installed, and the proper hardware drivers? Not with the same channels setup as well...

 

Your help is very much appreciated.

 

Thank you!

0 Kudos
Message 1 of 5
(2,757 Views)

@sensorsguy10 wrote:

 

Do I need to use MAX to setup the same channels, with the same names as the original LabVIEW VI, such that the executable file will recognize those and start receiving data?

The answer depends on what the VI is doing.

 

0 Kudos
Message 2 of 5
(2,754 Views)

The VI is recording data from 11 inputs (11 channels), and amongst other things, checking whether they are in a tolerance range, set by the user. 

0 Kudos
Message 3 of 5
(2,746 Views)
You have not provided the model numbers of the modules that are doing the acquisition. Also, your assumption about an exe is wrong. The device names, channels, tasks, scales, etc., have to match. You do this by exporting the hardware config on one and importing it on the other. You do this with the installer. Or, did you configure the acquisition inside the project?
0 Kudos
Message 4 of 5
(2,733 Views)

Modules are all NI 9219. 

 

I was not aware of having to export the hardware config and import it on the other computer. 

 

The acquistion is being done in the VI. The project so far only includes the VI. How would I configure the project to include the acquistion? 

0 Kudos
Message 5 of 5
(2,728 Views)