Showing results for 
Search instead for 
Did you mean: 

Error with database



I am learning on database which I encountered the error stated on the title. I couldn't troubleshoot the error. I have attached the files and image of error to this thread. Thank you for your help.


I am using Xampp software for database, ODBC 32bit for creating UDL file.



Download All
0 Kudos
Message 1 of 9

Hi NightKoh96,


Please check this link ( It may help you!




Message 2 of 9

Hi Karthiga,


Sorry, I don't understand the link you provided as I am revising/learning for my LabVIEW which I used since last year. By the way, today I tried again and I get different error. The following error, I have attached a screenshot to my reply.

0 Kudos
Message 3 of 9

I think, someone had the same error as you and they were discussing about that error in that link which I provided. But still, you are getting a different one like - "The table name given is blank".

As they already quoted in that link, you can try with giving table name, a default value. (Data operations -> Make current value as default)

Because, if you did not give any default value as your table name, it would be reinitialized to empty string during next execution. It may be the reason for your error.




Message 4 of 9

For the future. Go inside the "DB Tools Insert", find the output "Insert Query" in the "DB Tools Build Insert" function and put a probe there. Here you will see the body of the SQL request. Then many questions you will disappear.

Labview 4.0, 5.0, 6.1, 8.6, 2009, 2011, 2012, 2014
If you do not know something, ask me.
Message 5 of 9

Hi Borjomy,


Can you show me how you put a probe at the "Insert Query" in the "DB Tools Build Insert"? Thank you.

0 Kudos
Message 6 of 9

How do you use your VI "database trial"? 


I assume that currently you use it "manually", i.e. you select the Enum-Value and then run the VI once, since the connector pane is empty... Am I correct?


That's a problem, because the database-connection that you open when running this VI once with enum "Open Connection" will not persist when you run the VI manually a second time, this time perhaps with the enum-value "Login". Since the connection refnum is invalid you cannot expect to get a valid responce from the database VIs you use in that case.


Regards, Jens

Kudos are welcome...
0 Kudos
Message 7 of 9

Don't waste your time with this.


The OP can't bothered to troubleshoot his own code.

0 Kudos
Message 8 of 9
Thanks for the link. As the Database still has no connector pane in that thread, it's probably the same problem. VI is started several times manually, and the DB-refnum does not persist.

Regards, Jens
Kudos are welcome...
0 Kudos
Message 9 of 9