LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Analog input doesn't work after upgrading computer and LabView version

Solved!
Go to solution

Hello,

 

I'm a graduate stduent and I took over an instrument with two DAQ systems and LabView from my senior. I'm using LabView and DAQmx to control the temperature, mass flow, and valves of the instrument. I upgraded my computer and installed a newer version of LabView and DAQmx. When I try to run the system with a newer version of LabView, it has no error but analog input doesn't work. All the values of thermocouples and mass flow controllers are zero (in both DAQ systems). However, digital outputs (in both DAQ systems) are working well so I can control fans and valve's on/off via LabView.

 

I attached the information of the DAQ system, the previous version that I used and the newer version that I upgraded:

 

- DAQ system: NI PCI-6221 with SCB-68, NI USB-6001

- Previous: Windows XP, LabView 2011, DAQmx 14.5

- Now: Windows 7, LabView 2012, DAQmx 15.5.1

 

- Installation order I did: NI developer Suite 2012 DS2 (3 DVDs) > NI device driver DVD (Aug 2012) > DAQmx 15.5.1 (from website)

 

- What I did after installation: reboot computer, re-set DAQ system and self-test via NI MAX, save LabView 2011 VI files to LabView 2012 VI files, unplug DAQ system and plug again.

 

But, analog input still doesn't work... I tested USB-6001 with a previous computer again just in case and it worked well. So, I don't think it's physical problem... I checked all the compatibilities but no problem with it.

 

Can I get some advice on this? I'm not used to using LabView and I might have missed something. 

 

Thank you in advance.

0 Kudos
Message 1 of 5
(255 Views)
Are you using analog inputs on the PCI-6221, USB-6001, or both? Same with digital I/O?
In the LabVIEW code, what are the names of the instruments? The default naming scheme is Dev1, Dev2 ... But, I usually give them a more meaningful name in MAX. When you look in MAX, do the names of the instruments match the LabVIEW code?
Are you positive you would catch errors occurring with the DAQ instruments? If you upload the code that communicates with the DAQ instruments, that will give me a better idea.
0 Kudos
Message 2 of 5
(239 Views)

Yes, I'm using analog inputs on both PCI-6221 and USB-6001 and it's the same with digital I/O.Their names are default naming, Dev1 (PCI-6221) and Dev2 (USB-6001). I'm sure the name is matching with the code. I attached the subVIs to create channels for analog input and all the VIs I'm using. I run the program using 'TAG Main Program v10_SJ.vi'

 

Thanks!

0 Kudos
Message 3 of 5
(233 Views)
Solution
Accepted by topic author Jeon17

Wow, I'm very sorry you had to inherit this program. It's very hard to debug anything that takes 30 monitors to view!

 

One thing I noticed is that you are using custom scales for some of the analog inputs. Have you set those custom scales up in MAX?

Message 4 of 5
(206 Views)

Yes, it's really huge! And I wanted to reply yesterday but I couldn't because the new member could only post two posts a day😂

 

Anyway, I checked the custom scales up in MAX and it was empty. I exported custom scales information from the old computer and imported it to the new one. And it worked! Now I can read analog input without any problem. Thank you for your help!

 

Message 5 of 5
(117 Views)