LabVIEW Idea Exchange

About LabVIEW Idea Exchange

Have a LabVIEW Idea?

  1. Browse by label or search in the LabVIEW Idea Exchange to see if your idea has previously been submitted. If your idea exists be sure to vote for the idea by giving it kudos to indicate your approval!
  2. If your idea has not been submitted click Post New Idea to submit a product idea to the LabVIEW Idea Exchange. Be sure to submit a separate post for each idea.
  3. Watch as the community gives your idea kudos and adds their input.
  4. As NI R&D considers the idea, they will change the idea status.
  5. Give kudos to other ideas that you would like to see in a future version of LabVIEW!
Top Kudoed Authors
cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW Version conversion tool

Hi All,

 

I saw in the Forums,Developer are spending more time on the convertion of the programs from UP to Down or Down to UP due to their requirment.

if NI provides the add on tool for Converting Up/Down,Down/Up.

 

it is easy to use and they can spend more time on other part of Developmnet.

 

Version tool.png

13 Comments
Knight of NI

It is already in LabVIEW: File->Save For Previous. This works for LabVIEW 8.0 and newer.  I see no reason NI should invest time in make a down convert tool to take new code and put it in a really old version of LabVIEW.

 

For the up convert, you just need to open and save the VI in the new version of LabVIEW.  I usually do a mass compile.  In newer versions of LabVIEW, this works for VIs that were last saved in 6.0


There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
Proven Zealot

patibandla: What would you expect that tool to do that LabVIEW does not already do? Convert up happens on load. Convert down happens with Save For Previous. What functionality do you believe is missing?

Member

I believe he was requesting a tool that could handle any conversion regardless of the versions of LabVIEW you have on your machine.

 

If, for example, you have a LV2012 vi but only have LV2009 available on your machine, you can't down convert. You have to go to the VI conversion board in the forum and ask for someone with LV2012 to save to previous for you. This tool would let you get the LV2009 file without needing LV2012.

Proven Zealot

Verywiseguy: The user requested up and down convert of the code, so I think he may have meant something else. I'll wait and see if we get a reply.

Member

Verywiseguy: it is correct what you are saying.some of users they will download code from the NI web,but they are not able to open because they are having older version of LabVIEW installed in their PC.

 

AristosQueue: for converting the code 6.1 to 2010 , I faced a lot of issues, compatability , and Functions missing issues. if NI provides this tool based on the NI installed softwares , LabVIEW can easily find and convert the VIs(incase of doing Manually).

this toll is not a part of LabVIEW ,it is a add-on tool. who is working on down/UP convertion based on their requirment, they will install.

 

 I saw in Forums, some people requesting 2013 to 6.1 version.In this case we have to do two tair convertion. it is difficult to install 8.6 vertion and 2013 version in the same PC. because of Driver compatability issues.

I feel it is more usefull for people who are working on the refactorising the code.

Knight of NI

How many people are actually still using 6.1?  That software is well over 10 years old.  And your upgrade issues were most likely drivers related (DAQ vs DAQmx).  That has nothing to do with LabVIEW.

 

I still hold that this is such a small niche.  NI has MUCH bigger fish to fry than trying to add more support for obsolete software.


There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
Member

I purposed this idea five years ago, did not get much momentum.
Since, I have installed LabVIEW 7.1.1 to LabVIEW 2014 on one PC to do up or down conversion if I ever needed to.
They are times you cannot share you code online for simple version conversion, that may be due to company’s policy.


https://www.labviewhacker.com

Proven Zealot

> AristosQueue: for converting the code 6.1 to 2010 , I faced a lot of issues, compatability , and

> Functions missing issues. if NI provides this tool based on the NI installed softwares , LabVIEW

> can easily find and convert the VIs(incase of doing Manually).

 

LabVIEW already does everything that we know how to do automatically. I do not know what issues you faced, but we take a great deal of time with every upgrade to put as many smarts into LV as we know how to do to maintain that compatibility. The tool you're asking for for *upgrades* already exists... it is LabVIEW.

Active Participant

A tool might be useful, but not built into LabVIEW- this would create a tidal wave of patches and service packs.

Knight of NI
Excellent reason to keep SSP up-to-date. Even if you stick to an older version, you would still have the newest version on hand to do any down-converting yourself. Those using anything older than 8.0 can use the conversion board.