Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

Labview CE 2020 connects to raspberry but CE 2021 does not

Go to solution

Hi !


I wanted to move from Labview CE 2020 to 2021 but it seems there is a problem with the toolkit. I have a fresh installation of Raspberry Pi OS (October 30th 2021) into a Raspberry Pi 3B.


In both cases (LV2020 and LV2021) I perform exactly the same steps, in Tools-Hobbyist-Target Configuration.


  1. I successfully establish connection to RasPi in the 1st screen ("Connection").
  2. The problem appears in "Installation". While in LV2020 this step completes ok and the correct "Installed Version" is displayed, in LV2021 the "Installed Version" remains blank, although the message "Target configuration updated" appears. Clicking in "Launch example" in LV2020 drives me to a project that I can connect to RasPi, but in LV2021's project connection to Pi fails.
  3. Having searched in the forum, (this topic), I have disabled Pi's 1-wire interface (don't understand why..) but it didn't help.

Thanks in advance for any ideas,


0 Kudos
Message 1 of 30

Very interesting.  Sorry I have not used CE 2021 so I cannot offer any assistance but good troubleshooting and I will be interested in what the issue is here.

David Wilt
The New Standard LLC
0 Kudos
Message 2 of 30

I also tried with CE2021 and failed terribly... I'm still trying to figure what went wrong. 

Fingers crossed... let me try it again 
will update soon


Love Diwan
Solution Architect(Electromechanical)
0 Kudos
Message 3 of 30
Accepted by topic author dfousek

Good evening all!

The installation failed on my Raspberry Pi for the following reasons:

  • The Target Configuration.vi generated an invalid /etc/apt/sources.list file on the Raspberry Pi. The password for the Raspberry Pi was written into the file. This meant the MakerHub feed was not added to the list of packages. The /etc/apt/sources.list file is not changed if it already contains an entry for http://feeds.labviewmakerhub.com/
  • The installation of lvrt21-schroot is dependent on the dh-systemd package. This package was included in the previous Pi OS based on Debian Buster. dh-systemd is a transitional package linking to the debhelper package. The October 30th 2021 release of the Pi OS is based on Debian Bullseye and does not contain the dh-systemd package.

Please can NI update the dependency list for lvrt21-schroot to use debhelper instead of dh-systemd?


It is possible to install the software from the command line 🙂

Here is the procedure I used to install lvrt21-schroot_21.0.0-1 on a fresh installation of the October 30th 2021 Raspberry Pi OS:


1. Change the default password for the Pi account on the Raspberry Pi.
2. Setup a WiFi or Ethernet connection from the Raspberry Pi to your router.
3. Setup the Raspberry Pi configuration as shown below




4. SSH into the Raspberry Pi or open a terminal window on the Raspberry Pi desktop.

5. Enter the commands shown in the code block below.
Note: The text may wrap due to the web browser window size. I recommend copying the text into a text editor to see the original formatting.


sudo sh -c 'echo "deb [trusted=yes] http://feeds.labviewmakerhub.com/debian/ binary/" >> /etc/apt/sources.list'
# Check the contents of the /etc/apt/sources.list file
cat /etc/apt/sources.list

The contents the file should be

deb http://raspbian.raspberrypi.org/raspbian/ bullseye main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ bullseye main contrib non-free rpi
deb [trusted=yes] http://feeds.labviewmakerhub.com/debian/ binary/

The file can be edited if required using the command sudo nano /etc/apt/sources.list


6. Enter the commands shown in the code block below.


sudo apt-get update
# Install the dependencies
sudo apt-get install -y python schroot debhelper
cd Downloads
# Download and install lvrt21-schroot without the dh-systemd dependency
apt-get download lvrt21-schroot:armhf
sudo dpkg -i --ignore-depends=dh-systemd lvrt21-schroot_21.0.0-1_armhf.deb


I was able to connect to the Raspberry Pi from the LabVIEW Project Explorer.









Hope this works on your system.


Message 4 of 30

Excellent.. worked for me with CE 2021 and pi 4.

Thank you for the detailed steps.

As pointed out, the sources.list was not updated correctly when the installer was launched from the LabVIEW.

Following your suggestion of fixing the sources.list file and installing the labview runtime manually solved the issue.. 




The Installed Version field which was empty before now shows correctly.

A very well deserved thanks and kudos.

- Ravi Kumar

Labview 8.2
0 Kudos
Message 5 of 30

Hello Andy, 

It worked for me as well many thanks..
next i'm trying to build some user interface for my application on pi, any suggestions will be of great help.  


Love Diwan 

Solution Architect. 


Love Diwan
Solution Architect(Electromechanical)
0 Kudos
Message 6 of 30

@lovediwan wrote:

next i'm trying to build some user interface for my application on pi, any suggestions will be of great help.


Use the NI G Web Development Software.

David Wilt
The New Standard LLC
0 Kudos
Message 7 of 30



Have already started working on that.... 

any straight forward example... 



Love Diwan
Solution Architect(Electromechanical)
0 Kudos
Message 8 of 30

@lovediwan wrote: 

any straight forward example... 

 I following this to get me started with the NI G Web Development Software: https://www.mediamongrels.com/make-ing-with-labview-raspberry-pi-part-4-user-interfaces-with-labview...

David Wilt
The New Standard LLC
0 Kudos
Message 9 of 30

Hello Andy !


It worked for me also 😊 but with 1 modification, since my system wasn't anymore a new  and clean one, but had already the Labview 2020 system on it.


So the last of your command list (sudo dpkg -i --ignore-depends=dh-systemd lvrt21-schroot_21.0.0-1_armhf.deb) was giving errors related to the already installed Labview 2020 version.


When I uninstalled it with: sudo dpkg -r lvrt20-schroot then, it executed fine and then the Hobbyist Configuration displayed the correct runtime version (21.0.0-1).


Thanks 🙏 again for your help (during weekend).


PS. Disabling the 1-wire interface in Raspberry Configuration, was it really necessary with LV2021 ?



Message 10 of 30